SMSSP3_OM07_MPGD.cover

Operations Manager 2007용 Microsoft Systems Management Server 2003 서비스 팩 3 Management Pack 가이드

Microsoft Corporation

게시 날짜: 2007년 5월

사용자 의견

이 문서에 대한 제안이나 의견이 있으시면 smsdocs@microsoft.com으로 보내 주십시오. 사용자 의견을 보내실 때는 해당 Management Pack 가이드의 제목을 알려 주시기 바랍니다.


SMSSP3_OM2007_MPGuide.copy

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2007 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


Microsoft System Management Server 2003 Management Pack for Operations Manager 2007

Microsoft® System Management Server 2003 Management Pack for Operations Manager 2007에서는 SMS 2003 모니터링을 위한 새로운 기능과 향상된 기능을 제공합니다.

Management Pack 리소스

기능 및 리소스에 대한 자세한 내용은 다음 항목을 참조하십시오.

System Management Server 2003 Management Pack 개요

  • Management Pack 모니터링 시나리오
  • SMS 2003 Management Pack 배포
  • SMS 2003 Management Pack의 운영 작업 수행
  • SMS 2003 Management Pack 문제 해결
  • Microsoft System Management Server 2003 Management Pack용 참조


System Management Server 2003 Management Pack 개요
참고 항목

이 가이드에서는 SMS 2003 Management Pack에 대한 배포 및 기술 정보를 제공합니다. 이 정보를 통해 Management Pack의 배포 계획을 세우고, Management Pack에서 제공하는 기능을 이해하고, 이러한 기능을 IT 조직에 유용하게 활용하는 방법을 이해할 수 있습니다.

System Center Operations Manager 2007 Management Pack for SMS에서는 다음을 포함하여 SMS 2003 모니터링을 위한 향상된 기능을 제공합니다.

  • WMI(Windows Management Instrumentation), IIS(인터넷 정보 서비스), BITS(Background Intelligent Transfer Service), Microsoft SQL Server™ 등의 주요 종속 서비스를 비롯한 모든 SMS 2003 서비스의 시작 및 중지 모니터링
  • SMS 관리자에게 중요한 SMS 상태 메시지 경고
  • 주 사이트 서버와 관리 지점 모두에서 DDR(검색 데이터 기록), 소프트웨어 인벤토리, 하드웨어 인벤토리, 상태 메시지 및 소프트웨어 미터링의 백로그 모니터링
  • 시스템 리소스 사용량 모니터링
  • 처리 속도 모니터링
  • 뷰 및 보고서를 사용하여 여러 SMS 성능 카운터의 성능 추세 모니터링
  • 모든 경고 및 처리 규칙에 대한 제품 기술 자료 내용
  • 모든 SMS 2003 컴퓨터 및 컴퓨터 그룹 검색
  • 뷰
  • SMS 2003 관리 지점 및 서버 그룹의 성능, 가용성 및 구성을 표시하는 보고서. 여기에는 성능, 구성 및 가용성 추세에 대한 Systems Center Operations Manager 2007의 향상된 보고 기능을 제공하는 연결된 보고서가 포함됩니다.
  • Device Management Feature Pack의 모니터링
  • SMS Administrator 콘솔 응용 프로그램을 실행하기 위한 작업
  • 모든 SMS 서버 역할 및 SMS 고급 클라이언트의 상태가 들어 있는 상태 뷰
  • 중요한 SMS 서버 및 SMS 클라이언트 정보에 대한 서비스 검색
  • SMS Site Backup 서비스를 실행할 때 서비스 사용 불가능 경고 제거
  • SMS 사이트 계층 구조에 대한 토폴로지 다이어그램(SMS 2003 서비스 팩 3 필요)
  • SMS 프로그램 속성을 통해 구성할 수 있는 배포된 프로그램의 실행 오류에 대한 SMS 2003 SP3(서비스 팩 3) 경고

모니터링 시나리오 및 기능에 대한 자세한 내용은 Management Pack 모니터링 시나리오를 참조하십시오. SMS 2003 Management Pack은 다음 작업에는 사용되지 않습니다.

  • SMS 1.2, SMS 2.0, SMS 2003 SP2에 대한 모니터링
  • 혼합 SMS 환경 모니터링. 혼합 환경에서는 SMS 1.2, SMS 2.0 및 SMS 2003을 함께 설치하여 실행할 수 있습니다.
  • SMS 고급 클라이언트를 실행하는 SMS 클라이언트 전용 컴퓨터에 대한 제한된 모니터링
  • 설치된 SMS 2003을 수정하지 않고 관리하는 기본 모니터링 솔루션 제공. 규칙 임계값은 설치된 SMS 2003에 따라 다르므로 고객이 규칙을 직접 사용자 지정해야 합니다.

이 섹션에서

이 업데이트의 새로운 기능

필요한 지식

지원되는 SMS 구성

참고 항목

개념

Management Pack 모니터링 시나리오
SMS 2003 Management Pack 배포

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


이 업데이트의 새로운 기능

Systems Management Server 2003 Management Pack for Operations Manager 2007에는 유지 관리 모드가 포함되어 있습니다. 유지 관리 모드에 있을 때는 SMS 소프트웨어가 클라이언트 컴퓨터에서 실행되는 동안 클라이언트 컴퓨터에서 Operations Manager 경고를 제거합니다.

SMS 2003의 유지 관리 모드 업데이트

System Management Server 2003에서 컴퓨터에 소프트웨어를 배포할 때 대상 컴퓨터에서 생성되는 Operations Manager 규칙 기반 경고를 임시로 비활성화해야 할 수 있습니다. 예를 들어 서버에 핫픽스 및 보안 패치를 배포하려면 스레드와 서비스를 종료해야 할 수 있습니다. Management Pack에서 이러한 서버의 스레드나 서비스를 모니터링할 경우 수많은 Operations Manager 경고가 생성되어 Operations Manager 서버에 걸리는 부하가 커질 수도 있기 때문입니다.

Disable MOM alerts while this program runs 확인란을 선택하면 배포된 소프트웨어가 종료될 때까지 Operations Manager 경고가 생성되지 않습니다. SMS 관리자는 SMS 패키지 프로그램 속성에서 이 확인란을 설정할 수 있습니다. 이 옵션을 설정하면 클라이언트 컴퓨터에서 해당 프로그램을 실행하는 동안 클라이언트 컴퓨터를 대상으로 하는 모든 Management Pack에 대해 Operations Manager 경고가 제거됩니다.

이 옵션이 선택되어 있으면 대상 컴퓨터에서 보급이 실행될 때 Operations Manager 에이전트는 유지 관리 모드로 설정됩니다. SMS 에이전트에서는 Operations Manager 에이전트에 시간 제한 설정도 제공합니다. 대상 컴퓨터에서 보급이 실행된 후에는 SMS 클라이언트 에이전트가 해당 컴퓨터에서 Operations Manager 에이전트 모니터링을 다시 시작합니다. 이후에 경고를 트리거하는 모든 이벤트는 정상적으로 보고됩니다.

대상 컴퓨터에서 소프트웨어 배포를 실행하지 못할 경우 다음 작업이 수행됩니다.

  • 배포 시 오류 코드가 반환된 경우 SMS 에이전트는 배포에 성공했을 때와 같이 Operations Manager 에이전트를 유지 관리 모드에서 해제합니다.
  • 배포가 예기치 않게 실패하고 SMS 에이전트가 미리 정의된 제한 시간 내에 오류 코드를 받지 못한 경우 Operations Manager 에이전트의 유지 관리 모드가 종료됩니다.

SMS 2003 프로그램에 대해 유지 관리 모드 사용

SMS 2003 프로그램이 실행되는 동안 클라이언트 컴퓨터에서 유지 관리 모드를 설정하려면 다음 절차를 따르십시오.

SMS 2003 프로그램에 대해 유지 관리 모드를 설정하려면

  1. Systems Management Server 콘솔에서 Systems Management Server/Site Database - <site server name>/Packages로 이동합니다.

  2. 세부 정보 창에서 Program을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭합니다.

  3. Program Properties 대화 상자에서 MOM 탭을 클릭합니다.

  4. Disable MOM alerts while this program runs를 선택하고 OK를 클릭합니다.

SMS 2003 프로그램에 대해 유지 관리 모드를 설정한 후에는 SMS 패키지가 배포 및 실행될 때 클라이언트 컴퓨터가 유지 관리 모드로 설정됩니다.

참고
유지 관리 모드의 제한 시간은 Program Properties 대화 상자의 Requirements 탭에서 Maximum allowed runtime 속성을 선택하여 설정합니다.

SMS 2003 사이트 토폴로지

Microsoft Operations Manager(MOM) 2005에서는 SMS 2003의 계층 구조 다이어그램이 SMS 2003 사이트 계층 구조로 바뀌었습니다. 이제 계층 구조 뷰에는 서버 역할이 토폴로지 뷰로 표시됩니다.

구성 스크립트 제거

SMS 2003 SP2 이상이 권장되는 SMS 버전이므로 구성 스크립트가 제거되었습니다.

SMS 2003의 보고서

SMS 2003에는 사이트 시스템 역할을 기준으로 한 성능 카운터와 개체 처리 카운터를 기준으로 한 성능 카운터(예: DDR 관련 카운터)에 중점을 둔 새로운 보고서가 포함되어 있습니다. 새 보고서에 대한 자세한 내용은 SMS 2003의 보고서를 참조하십시오.

참고 항목

개념

SMS 2003의 보고서
SMS 2003의 스크립트


필요한 지식

SMS 2003 Management Pack을 배포 및 사용하려면 다음 지식과 기술을 갖추고 있는 것이 좋습니다.

  • Operations Manager 2007 모니터링 기능에 대해 알고 있어야 합니다. Operations Manager 2007에 대한 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.
  • Operations Manager 2007 디자인 아키텍처와 조직에 배포된 디자인 아키텍처를 이해해야 합니다.
  • System Center Operations Manager 2007 배포 가이드에 설명된 대로 Management Pack을 배포하기 위한 권장 절차에 익숙해야 합니다.
  • SMS 개념 및 용어를 알고 있어야 합니다. SMS 2003에 대한 자세한 내용은 Systems Management Server 2003 제품 설명서 웹 페이지(http://go.microsoft.com/fwlink/?linkid=9502)를 참조하십시오.

참고 항목

개념

Management Pack 모니터링 시나리오
SMS 2003 Management Pack 배포

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행


지원되는 SMS 구성

SMS 2003 및 Systems Center Operations Manager 2007의 요구 사항은 해당 제품의 배포 가이드에 설명되어 있습니다. SMS 2003 Management Pack에서는 SMS 2003을 모니터링합니다. SMS 2003 SP2 이상의 릴리스를 사용하는 것이 좋습니다. SMS 2003 SP1을 실행하려면 스탬프 스크립트를 실행해야 합니다.

소프트웨어가 배포되는 동안 유지 관리 모드를 설정하고 토폴로지를 Operations Manager 2007과 매핑하려면 SMS 2003 SP3 이상이 필요합니다.

이 SMS 2003 Management Pack에서는 SMS 1.2 , SMS 2.0 또는 Configuration Manager 2007을 모니터링하지 않습니다.

참고 항목

기타 리소스

Microsoft System Management Server 2003 Management Pack용 참조
SMS 2003 Management Pack 문제 해결


Management Pack 모니터링 시나리오

Microsoft® Systems Management Server(SMS) 2003에서는 SMS 2003 모니터링을 위한 새로운 기능과 향상된 기능을 제공합니다. 다음 단원에서는 SMS 2003 Management Pack에서 지원하는 주 시나리오와 해당 기능에 대해 설명합니다.

서비스 가용성

서비스 검색

가용성 모니터링

상태 모니터링

에이전트 없는 모니터링 지원

성능 임계값 모니터링

성능 모니터링

중요한 SMS 상태 메시지 모니터링

사이트 시스템 모니터링

SMS Executive 크래시 덤프 모니터링

백로그 모니터링

일반 상태 모니터링

SMS 패치 관리 모니터링

SMS Site Backup 서비스 모니터링

모든 경고에 대한 제품 기술 자료 내용

모든 SMS 2003 서버 및 클라이언트 역할의 컴퓨터 그룹

확장된 모니터링

소프트웨어 배포 프로그램 실행 상태

서비스 가용성

서비스 가용성 시나리오에서는 System Center Operations Manager 2007의 서비스 가용성 기능과 NT 이벤트 시스템 로그의 서비스 제어 관리자 이벤트를 모두 사용하여 SMS 2003 서비스의 가용성을 모니터링합니다. 서비스 가용성을 모니터링할 경우 생성되는 경고는 다음과 같습니다.

  • SMS 사이트 시스템에서 SMS 기반 서비스가 중지될 때의 경고
  • SMS 사이트 시스템에서 WMI(Windows Management Instrumentation)와 같이 중요한 SMS 종속 서비스가 중지되거나 시작되지 않을 때의 경고
  • SMS 사이트 시스템에서 Microsoft SQL Server™, IIS(인터넷 정보 서비스) 및 BITS(Background Intelligent Transfer Service) 등의 다른 SMS 종속 서비스가 중지되거나 시작되지 않을 때의 경고
  • SMS Site Backup 서비스가 시작 및 중지될 때의 경고. 이를 통해 백업이 진행되는 기간 동안 모니터링하고 다른 SMS 서비스의 중지 이벤트를 SMS Site Backup 서비스에 연결할 수 있습니다.

서비스 검색

서비스 검색은 관리되는 컴퓨터의 데이터, 서버 역할 및 구성 요소를 검색하는 프로세스입니다. 서비스 검색 프로세스에서는 SMS 서버 및 SMS 고급 클라이언트에 대한 정보를 반환하며 이 프로세스를 통해 상태 모니터링 뷰에 SMS 서버 및 SMS 클라이언트 역할을 표시할 수도 있습니다.

서버 관련 서비스 검색 데이터는 Management Pack이 배포된 후부터 수집되어 System Center Operations 콘솔에 표시되기 시작합니다. 따라서 서비스 검색 데이터가 처음으로 수집되기 전까지는 특정 작업의 역할, 컴퓨터 그룹 및 대상 컴퓨터를 식별해야 하는 기능은 사용할 수 없습니다.

SMS 2003 Management Pack에서는 다음 이벤트 처리 규칙을 사용하여 서비스 검색 스크립트를 실행합니다.

  • SMS 클라이언트\SMS 클라이언트 - 고급\SMS 2003 서비스 검색
  • SMS 서버\SMS 서버 - 일반\SMS 2003 서비스 검색

기본적으로 스크립트는 비동기 시간 제한 공급자를 사용하여 서비스 검색 데이터를 24시간마다 수집합니다. 공급자는 다음 작업도 실행합니다.

  • Management Pack의 배포
  • Management Pack에 대한 구성 변경
  • Operations Manager 2007 에이전트 시작 및 중지

가용성 모니터링

이번 릴리스의 SMS Management Pack에서는 SMS 2003 서버 가용성 보고서, SMS 2003 관리 지점 가용성 보고서 및 SMS 2003 사이트 서버 가용성 보고서라는 세 가지 보고서가 제공됩니다.

관리 지점 가용성 보고서는 구성 요소 상태 기반 가용성 보고서입니다. 관리 지점 가용성은 새 알고리즘, 새 규칙 및 SMS 2003 관리 지점 가용성 모니터 스크립트를 기반으로 합니다.

이 단원에서 설명하는 새 보고서를 포함하여 모든 보고서는 OperationsManager 데이터베이스에 대해 실행되며, OperationsManager 데이터베이스에만 저장 프로시저를 만들었던 이전 스크립트에 비해 보고 기간을 길게 지정할 수 있습니다.

서버 가용성에 대한 자세한 내용은 SMS 2003의 스크립트 및 SMS 2003의 보고서를 참조하십시오.

상태 모니터링

상태 모니터링 프로세스에서는 모든 서버나 특정 컴퓨터 그룹으로 범위가 지정된 서버의 상태를 시각화하여 보여 줍니다. Management Pack에서는 이 기능을 지원하기 위해 컴퓨터 그룹의 특정 목록을 사용합니다. 서버 역할 및 구성 요소는 서비스 검색을 통해 관리되고 구성 요소 상태는 서비스 가용성, 성능 임계값 및 관리 지점 상태의 규칙 집합으로 관리됩니다.

아래 표를 참고하면 SMS 구성 요소를 모니터링할 때 해당 구성 요소의 상태를 색별로 구분할 수 있습니다.

SMS 서버 상태 모니터링

SMS 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
SS(사이트 서버) | 예 | 예 | 예
MP(관리 지점) | 예 | 예 | 예
DB(사이트 데이터베이스) | 예 | 예 | 예
DP(배포 지점) | 예 |  |
SLP(서버 검색 지점) | 예 |  | 예
발신자 | 예 |  | 예
RP(보고 지점) | 예 |  | 예
공급자 | 예 |  | 예
CAP(클라이언트 액세스 지점) | 예 |  | 예
성능 | 예 | 예 | 예
참고
배포 지점 구성 요소의 상태를 변경하는 모니터링 규칙은 없으므로 이 구성 요소(있는 경우)는 녹색 상태로만 보고됩니다. 배포 지점 구성 요소가 없으면 콘솔에 상태가 표시되지 않습니다.

SMS 클라이언트 상태 모니터링

SMS 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
클라이언트 서비스 | 예 |  | 예

에이전트 없는 모니터링 지원

SMS 2003 Management Pack에서는 에이전트 없는 관리되는 컴퓨터에 대해 아래에 나열된 기능을 제외한 모니터링 기능을 지원합니다.

  • 중요한 SMS 상태 메시지 모니터링
  • 사이트 시스템 상태 모니터링
  • 토폴로지

위의 기능을 지원하는 스크립트는 다음과 같습니다.

  • SMS 2003 SMS 상태 메시지 모니터
  • SMS 2003 사이트 시스템 요약 작성기 모니터
  • SMS 2003 Server Topology: Discovery

이러한 스크립트에서 SMS 네임스페이스에 액세스하기 위해서는 SMS 공급자에 대해 로컬로 실행해야 합니다. 스크립트에서 SMS 네임스페이스를 찾을 수 없으면 스크립트 오류 이벤트가 발생합니다.

성능 임계값 모니터링

성능이 저하되면 지연이 발생하고 시간, 성능 및 데이터 정확도 측면에서 고객 SLA(서비스 수준 계약)에 영향을 줄 수 있습니다. 따라서 SMS 인프라의 중요한 성능 문제를 찾아 해결하는 것이 중요합니다. 성능 임계값 모니터링 프로세스에서는 다음과 같은 경우에 경고를 생성합니다.

  • SMS 사이트 시스템의 CPU, 페이징 파일 및 메모리와 관련된 컴퓨터 수준의 일반적 상태 메트릭이 특정 임계값을 초과할 경우
  • Microsoft SQL Server™의 총 사용자 연결 수가 임계값을 초과할 경우
  • SMS 사이트 서버 수신함에 있는 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR(검색 데이터 기록), 소프트웨어 인벤토리 및 하드웨어 인벤토리 기록과 같은 SMS 파일의 총 수가 특정 임계값을 초과할 경우
  • SMS 관리 지점 메시지 대기열에 있는 상태 메시지, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리 관련 SMS 메시지의 총 수가 특정 임계값을 초과할 경우

성능 모니터링

성능 모니터링을 통해 백로그, 처리 속도 및 주요 SMS 개체의 총 수에 대한 추세를 조사함으로써 손쉽게 문제를 파악하고 미리 해결할 수 있습니다. 성능 추세 분석 프로세스에서는 Operations Manager 2007 뷰 및 보고서를 사용하여 다음과 같은 추세를 시각적으로 모니터링합니다.

  • SMS 사이트 서버의 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리 및 상태 메시지와 관련된 수신함의 백로그 파일
  • SMS 사이트 서버의 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리 및 상태 메시지 처리 속도
  • SMS 사이트 서버의 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리 및 상태 메시지 총 수
  • SMS 관리 지점 서버 메시지 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 소프트웨어 미터링, 상태 메시지 및 기타 SMS 개체와 관련된 메시지의 백로그
  • SMS 관리 지점 서버 메시지 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 소프트웨어 미터링, 상태 메시지 및 기타 SMS 개체의 처리 속도
  • SMS 관리 지점 서버 메시기 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 릴레이 및 상태 메시지의 총 수
  • SMS 사이트 데이터베이스 서버의 총 SQL Server 사용자 연결 수
  • SMS 사이트 시스템의 CPU, 페이징 파일 및 메모리와 관련된 컴퓨터 수준의 상태 메트릭
  • 실행 중인 SMS Executive 스레드의 총 수
  • IIS로 보내는 ISAPI 확장 요청의 처리 속도

중요한 SMS 상태 메시지 모니터링

SMS 인프라에서는 SMS 상태 메시지를 생성합니다. 중요한 서버 관련 SMS 상태 메시지를 확인하여 제때에 문제를 해결하는 것은 중요합니다. 이러한 문제는 일반적으로 SMS 인프라의 가용성, 성능, 구성 및 전반적인 상태에 대한 문제를 나타냅니다.

중요한 SMS 상태 메시지 모니터링 프로세스에서는 SMS 사이트 역할 상태에 영향을 주는 구성 요소 설치, 데이터베이스 연결 및 사이트 연결 등의 중요한 상태 메시지가 검색될 때 경고를 생성합니다. SMS 사이트 데이터베이스는 30분마다 한 번씩 중요한 SMS 상태 메시지를 검사합니다.

사이트 시스템 상태 모니터링

SMS는 한 시간에 한 번씩 SMS 사이트 시스템을 폴링하는 Site System Status Summarizer를 통해 정기적으로 사이트 시스템의 기본 상태를 모니터링합니다. 이 기능을 제대로 활용하려면 이 상태에 신속하게 대응하여 SMS 기능이 저하되지 않도록 해야 합니다. 사이트 시스템 상태 모니터링을 통해 SMS 사이트 시스템의 상태에 영향을 주는 SMS 사이트 시스템 요약 작성기 상태가 감지될 때 이를 모니터링하고 경고를 생성할 수 있습니다. 모니터링된 상태 메시지의 일부에는 종료 중인 SMS 사이트 시스템, 데이터베이스 영역이나 로그 영역 외부에서 실행되고 있는 SQL Server 실행 서버 및 실제 디스크 영역 외부에서 실행되고 있는 SMS 사이트 시스템에 대한 내용이 포함되어 있습니다.

SMS Executive 크래시 덤프 모니터링

SMS Executive 서비스 오류는 SMS 가용성에 영향을 주므로 크래시 덤프가 언제 발생하는지를 알고 근본적인 원인을 조사하는 것이 좋습니다. SMS Executive 서비스에 오류가 있으면 SMS\Logs\CrashDumps 디렉터리에 크래시 덤프 로그 하위 디렉터리가 만들어집니다. 이 하위 디렉터리 생성 작업은 모니터링되며 SMS Executive 서비스에 종속되어 있는 모든 SMS 서버 역할에 대해 경고가 생성됩니다.

SMS 2003 SMS Executive 크래시 덤프 모니터 스크립트는 가장 최근의 크래시 덤프만 보고합니다. 이는 마지막 크래시 덤프가 발생한 후 얼마나 오랜 시간이 경과되었는지에 관계없이 스크립트가 처음으로 실행된 때부터 SMS Executive가 제거되었다가 나중에 다시 설치될 때까지 적용됩니다.

관련 규칙은 Microsoft SMS 2003 Component Servers based on SMS Executive 규칙 그룹 아래에 있습니다.

  • SMS 2003 크래시 덤프: SMS Executive 모니터링

SMS 2003 크래시 덤프: SMS Executive 모니터링은 SMS 2003에서 60분마다 예약, 00:10에 동기화 시간 제한 이벤트 공급자를 사용하여 스크립트를 실행합니다. 요약 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • SMS 2003 크래시 덤프: SMS Executive 모니터링 스크립트 오류

SMS 2003 Crash Dumps: Monitoring SMS Executive script error는 발생할 수 있는 스크립트 오류 이벤트를 모니터링하고 이를 알립니다. 여기에는 모든 스크립트 오류를 보고하는 스크립트 오류 이벤트(번호 1102) 하나만 있습니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • SMS 2003 크래시 덤프: SMS Executive 크래시

SMS 2003 크래시 덤프: SMS Executive 크래시는 크래시 덤프 이벤트를 모니터링하고 이를 알립니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

백로그 모니터링

백로그가 많으면 지연이 발생하여 시간, 성능 및 데이터 정확도 측면에서 고객 SLA(서비스 수준 계약)에 영향을 줄 수 있습니다. 따라서 SMS 인프라의 중요한 성능 문제를 신속하게 찾아 해결하는 것이 중요합니다. 백로그가 지정된 기간 동안 다음 항목에 대한 임계값을 초과하면 경고가 생성됩니다.

  • SMS 사이트 서버 수신함에 있는 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR(검색 데이터 기록), 소프트웨어 인벤토리 및 하드웨어 인벤토리 기록과 같은 SMS 파일의 총 수
  • SMS 사이트 서버 대기열에 있는 스케줄러 작업, 보내기 요청, 소프트웨어 미터링 기록, DDR(검색 데이터 기록), 소프트웨어 인벤토리 및 하드웨어 인벤토리 기록과 같은 SMS 개체의 총 수

SMS 관리 지점 메시지 대기열에 있는 상태 메시지, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리와 관련된 SMS 메시지의 총 수

일반 상태 모니터링

일반 상태 모니터링 프로세스에서는 일정 기간 동안 SMS 서버의 상태 메트릭이 특정 임계값을 초과할 경우 경고를 생성합니다. 일반 상태 모니터링 프로세스는 다음 메트릭을 검사합니다.

  • 3시간 동안의 프로세서 시간 95%
    • Smsexec
    • Ccmexec
    • Total
  • 3시간 동안의 페이징 파일 사용률 98%

SMS 패치 관리 모니터링

SMS Administrator는 SMS 패치 관리 기능을 사용하여 기업의 클라이언트 및 서버 컴퓨터를 최신 보안 업데이트와 동기화합니다. 패치 관리 모니터링 프로세스에서는 SMS 패치 관리 처리 및 구성의 오류를 감지하며 다음과 같은 경우에 경고를 생성합니다.

  • SMS 패치 관리 동기화 프로세스가 실패할 경우
  • SMS 패치 관리 프로세스에서 SMS 배포 지점을 업데이트하는 데 실패할 경우

SMS Site Backup 서비스 모니터링

SMS 2003 백업 시작, 완료 또는 오류 시기를 알고 있으면 SMS 관리자가 백업 작업을 감사하는 데 유용합니다. SMS의 데이터, 정책 및 구성 백업을 정기적으로 실행하도록 SMS 백업 일정을 지정할 수 있습니다. 이 백업 프로세스의 오류를 모니터링하고 수정 작업을 수행하는 것이 좋습니다. SMS 백업 프로세스는 SMS Site Component Manager, SMS Executive 및 SMS SQL Monitor 서비스를 중지 및 시작하므로 이 프로세스가 성공할 경우에도 서비스 가용성에 영향을 줍니다. SMS 백업을 모니터링하면 백업 중에는 이러한 서비스 중지에 대한 경고가 제거되므로 해당 서비스에서 알려진 중단 시간을 추적할 수 있습니다. SMS Site Backup 서비스의 모니터링을 지원하는 규칙은 다음과 같습니다.

  • SMS 2003 서비스 실행 중지: SMS_SITE_BACKUP
  • SMS 2003 서비스 실행 시작: SMS_SITE_BACKUP
  • SMS 2003 상태: 사이트 백업이 성공적으로 완료됨
  • SMS 2003 상태: 사이트 백업에 실패함

모든 경고에 대한 제품 기술 자료 내용

관리자는 모든 경고에 대한 제품 기술 자료 내용을 참조하여 문제를 명확하게 파악하고 해결할 수 있습니다. 제품 기술 자료 내용에 액세스하려면 규칙 이름을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭한 다음 Product Knowledge 탭을 클릭합니다.

모든 SMS 2003 서버 및 클라이언트 역할의 컴퓨터 그룹

현재 컴퓨터 그룹 수준은 특정 SMS 서버 및 클라이언트 역할로 설정되어 있습니다. 따라서 관리자는 Operations Manager 2007 에이전트에 대한 규칙 복제를 보다 효율적으로 관리할 수 있습니다. 관리자는 기본 컴퓨터 그룹을 사용하지 않도록 설정하거나 기본 컴퓨터 그룹 및 컴퓨터 특성을 기준으로 새 컴퓨터 그룹을 정의할 수 있습니다.

확장된 모니터링

SMS 2003 Management Pack에 제공된 규칙은 SQL Server, IIS, Microsoft Windows® 2000 및 Windows Server® 2003 Base Operating System Management Pack에 대한 기본 서비스, 성능 측정 및 성능 임계값 모니터링에 적용됩니다. SMS 2003 Management Pack에서 이러한 Management Pack에 대해 기본 지원을 사용하도록 설정하거나, 비활성화된 설정을 유지하고 다른 Management Pack의 적절한 규칙을 사용하도록 설정할 수 있습니다.

  • SQL Server 종속성이 있는 SMS 사이트 데이터베이스 서버 및 관리 지점의 모니터링을 확장하려면 SQL Server Management Pack을 사용합니다.
  • 보고 지점, 관리 지점 및 서버 검색 지점에서 IIS를 모니터링하려면 IIS Management Pack을 사용합니다. IIS Management Pack을 사용하면 BITS를 사용하는 배포 지점을 모니터링할 수도 있습니다.
  • CPU, 디스크 및 메모리 통계와 같은 기본 Windows 구성 요소를 모니터링하려면 Microsoft Windows 2000 및 Windows Server 2003 Base Operating System Management Pack을 사용합니다.

SMS 2003 Management Pack에서 관련 규칙을 제공하지 않고 SMS 2003 인프라의 모니터링을 향상시키는 다른 Management Pack도 있습니다.

  • 확장성을 이유로 네트워크 로드 균형 조정을 사용하여 SMS 계층 구조의 여러 관리 지점을 지원하는 경우 Windows Network Load Balancing Management Pack을 사용합니다.
  • Active Directory 인프라의 상태를 모니터링하려면 Windows Active Directory® Directory Management Pack을 사용합니다.

사용자 환경에 Management Pack을 여러 개 배포할 경우 각 Management Pack의 규칙에 따라 같은 경고를 중복하여 받을 수 있습니다. 중복 모니터링 규칙을 사용하지 않도록 설정하면 배포된 Management Pack의 상태 뷰 정확도에 영향을 줄 수 있습니다. 따라서 중복 경고를 받을 것인지 배포한 각 Management Pack에 대해 상태 모니터링 작업을 수행할 것인지 신중하게 고려해야 합니다. 배포한 추가 Management Pack에 따라 이러한 중복 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다. 이러한 Management Pack을 설치한 후에는 Management Pack이 필요에 맞게 사용자 지정되고, 올바르게 구성되고, 적절한 규칙이 설정되었는지 확인합니다.

소프트웨어 배포 프로그램 실행 상태

SMS 고급 클라이언트에서는 Management Pack을 통해 프로그램 오류를 보고할 수 있습니다.

관리자는 Program Properties 대화 상자의 MOM 탭에 있는 Generate MOM alert if this program fails 확인란을 선택할 수 있습니다.

절차

SMS 2003 프로그램이 실행되지 않을 경우 Operations Manager 2007 경고를 사용하도록 설정하려면 다음 단계를 수행해야 합니다.

SMS 2003 프로그램에 대한 Operations Manager 2007 경고를 사용하도록 설정하려면

  1. Systems Management Server 콘솔에서 Systems Management Server/Site Database - <site server name>/Packages로 이동합니다.

  2. 세부 정보 창에서 Program을 마우스 오른쪽 단추로 클릭하고 Properties를 선택합니다. Program Properties 대화 상자가 열립니다.

  3. MOM 탭을 선택합니다.

  4. Generate MOM alert if this program fails to run 확인란을 클릭합니다. OK를 클릭합니다.

참고 항목

개념

SMS 2003 Management Pack 배포

기타 리소스

Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003 Management Pack 배포

Microsoft® Systems Management Server(SMS) 2003 Management Pack을 배포하기 전에 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)에 있는 Microsoft Operations Manager 2007 Deployment Guide를 검토하십시오. 이 단원에서는 Operations Manager Management Pack을 배포하기 위한 추가 지침을 제공합니다.

SMS 2003 Management Pack을 배포하려면 다음 절차를 따라야 합니다.

  • 모든 SMS 서버 구성 요소 컴퓨터에 Operations Manager 2007 에이전트를 배포합니다.
참고
Operations Manager 2007 유지 관리 모드나 토폴로지 매핑이 필요한 경우 SMS 2003 Management Pack을 가져오거나 Operations Manager 2007 에이전트를 설치하기 전에 SMS 2003 SP3을 배포해야 합니다.

  • Operations Manager 2007 구성 그룹으로 SMS 2003 Management Pack을 가져옵니다.
  • Operations Manager 2007 에이전트가 다른 컴퓨터에 프록시를 통해 연결할 수 있도록 SMS 공급자 및 SMS 사이트 데이터베이스 서버를 구성합니다.
  • 권장 테스트 및 파일럿 테스트 작업을 완료합니다.
  • 권장 조정 작업을 완료합니다.

이 단원의 내용

Operations Manager 2007 에이전트 배포

Management Pack 테스트 및 파일럿 테스트

Management Pack 사용자 지정

참고 항목

개념

Management Pack 모니터링 시나리오

기타 리소스

System Management Server 2003 Management Pack 개요
SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


Operations Manager 2007 에이전트 배포

Operations Manager 에이전트는 Operations Manager가 모니터링하는 각 컴퓨터에서 실행됩니다. SMS 2003 Management Pack에서 모니터링하는 컴퓨터 그룹을 보려면 이 가이드의 SMS 2003의 컴퓨터 그룹 단원을 참조하십시오. Operations Manager 2007 에이전트는 관리되는 컴퓨터에 대한 모니터링 데이터를 수집하고 수집한 데이터에 규칙을 적용한 다음 결과 데이터를 DCAM(Data Consolidator Agent Manager)에 보냅니다. 에이전트 컴퓨터에 대한 모니터링 기능은 Operations Manager 2007 서비스(HealthService.exe), Operations Manager 2007 호스트(MonitoringHost.exe) 및 에이전트 작업 계정에서 제공합니다.

Operations Manager 2007 에이전트를 배포하려면 Operations Manager 2007 설치 마법사나 SMS 소프트웨어 배포를 사용합니다. Operations Manager 2007 에이전트 배포 및 Operations Manager 2007 설치 마법사 사용에 대한 자세한 내용은 Microsoft Operations Manager 2007 Deployment Guide의 “Discovering Computers and Deploying MOM Agents”를 참조하십시오. 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

참고
Operations Manager 2007 에이전트는 SMS 공급자 컴퓨터에서 LocalSystem 계정이나 SMS 2003 WMI 네임스페이스 루트, root\cimv2, root\sms 및 SMS 레지스트리 키와 하위 키에 액세스하는 데 충분한 권한이 있는 계정을 사용하여 실행하는 것이 좋습니다.

사용자 환경에서 에이전트 없는 모니터링을 사용할 수 있는지 여부를 확인하려면 Management Pack 모니터링 시나리오의 에이전트 없는 모니터링 지원을 참조하십시오.

권한이 낮은 시나리오에서 실행할 수 있도록 에이전트 컴퓨터 구성

에이전트 컴퓨터에 대한 모니터링 기능은 Operations Manager 2007 서비스(HealthService.exe), Operations Manager 2007 호스트(MonitoringHost.exe) 및 에이전트 작업 계정에서 제공합니다. Microsoft Windows® 2000에서 에이전트 계정은 로컬 관리자 그룹의 구성원이어야 합니다. Microsoft Windows™ 2003에서는 일부 경우 에이전트의 에이전트 작업 계정에 낮은 권한의 계정을 사용할 수 있습니다. 그러나 필요한 권한 및 사용 권한에서 실행되는 Operations Manager 2007 서비스와 Operations Manager 2007 호스트 프로세스가 실행되는 작업 계정 및 사용자 컨텍스트를 SMS 2003 Management Pack 기능을 실행하는 데 필요한 권한 및 사용 권한으로 구성하려면 에이전트 컴퓨터에서 많은 사항을 수동으로 구성해야 합니다. Microsoft Windows Server™ 2003에서 에이전트 작업 계정에는 최소한 다음과 같은 사용자 권한과 사용 권한이 있어야 합니다.

  • 로컬 사용자 그룹의 구성원
  • Windows 이벤트 로그에 대한 액세스 권한
  • 감사 및 보안 로그 관리 권한(SeSecurityPrivilege)
  • "보안 감사 생성" 권한(SeAuditPrivilege)
  • 로컬 로그온 허용 권한(SeInteractiveLogonRight)

권한이 낮은 시나리오에서 SMS 2003 Management Pack을 실행하려면 에이전트 작업 계정에 사용되는 계정에 추가 권한 및 사용 권한이 있어야 합니다. 다음 표에서는 수동으로 구성해야 하는 액세스 권한에 대해 자세히 설명합니다.

SMS 2003 Management Pack에 필요한 액세스 유형

리소스 | 액세스 유형 | 지침
Windows 이벤트 로그 | 읽기 | 로컬 및 글로벌 정책을 사용하여 작업 계정에 감사 및 보안 로그 관리 권한을 부여해야 합니다.
SMS 레지스트리 키 | 읽기 | HKLM\Software\Microsoft\SMS 레지스트리 속성에 작업 계정을 추가하고 모든 하위 키에 상속되는 읽기 권한을 부여합니다.
Win32 서비스 레지스트리 키 | 읽기 | HKLM\System\CurrentControlSet\Services 로컬 사용자 그룹에 작업 계정을 추가합니다.
스크립트 생성 임시 파일 | 읽기 및 쓰기 | %Windir%\Temp 로컬 사용자 그룹에 작업 계정을 추가합니다. .
스크립트 생성 로그 파일 | 읽기 및 쓰기 | %Windir%\Microsoft Operations Manager 폴더 속성에 작업 계정을 추가합니다.
SMS 로그 파일 | 읽기 | \SMS\Logs 폴더 속성에 작업 계정을 추가합니다.
WMI 네임스페이스 | 읽기 | root 및 root\cimv2 필요한 작업이 없습니다.
SMS WMI 네임스페이스 | 읽기 | 필요한 작업이 없습니다.
SMS WMI 클래스 | 읽기 | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer 모든 인스턴스의 클래스에 작업 계정을 추가합니다.
기본 인스턴스에 대한 보안 로그인 권한 | 액세스 허가 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 보안 로그인에 대한 액세스 허가 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Security\Logins 노드에 작업 계정을 추가합니다.
기본 인스턴스의 마스터 데이터베이스 액세스(SMS 사이트 데이터베이스를 확인하는 데 필요) | 허용 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 마스터 데이터베이스에 대한 허용 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Databases\Master\Users 노드에 작업 계정을 추가합니다. 이 새 사용자와 관련된 모든 기본 권한을 유지합니다.
기본 인스턴스의 SMS 사이트 데이터베이스 액세스 | 허용 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 SMS 사이트 데이터베이스에 대한 허용 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Databases\<SMS site>\Users 노드에 작업 계정을 추가합니다. 이 새 사용자와 관련된 모든 기본 권한을 유지합니다.

참고 항목

개념

Management Pack 테스트 및 파일럿 테스트
Management Pack 사용자 지정
SMS 2003의 알려진 문제

기타 리소스

SMS 2003 Management Pack 문제 해결


Management Pack 테스트 및 파일럿 테스트

Microsoft Operations Manager 2007 Deployment Guide에 설명된 Management Pack을 테스트하기 위한 일반적인 권장 사항 외에도 이 단원에서는 SMS 2003 Management Pack에 적절한 테스트 및 파일럿 테스트 작업을 설명합니다. 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

테스트 작업

  • SMS 2003 컴퓨터 그룹이 SMS 2003을 실행하는 컴퓨터로 채워져 있는지 확인합니다.
  • 관련 규칙을 사용하도록 설정한 후 Operations Manager 2007의 뷰 및 보고서가 올바르게 작동하는지 확인합니다. 여기에는 SMS 처리 속도 및 SMS 백로그와 관련된 뷰가 포함됩니다.
  • 기본적으로 IIS 및 SQL Server Management Pack 등의 다른 Management Pack과 관련된 일부 규칙은 SMS 2003 Management Pack에서는 사용하지 않도록 설정됩니다. 배포한 추가 Management Pack에 따라 이러한 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.
  • 기본적으로 에이전트의 CPU, 메모리 및 네트워크 리소스에 주는 영향을 최소화하기 위해 모든 성능 측정 규칙은 사용하지 않도록 설정됩니다. 에이전트를 보다 세부적으로 모니터링하려는 경우 이러한 규칙을 사용하도록 설정할 수 있습니다.
  • SMS 공급자 컴퓨터 및 SMS 사이트 데이터베이스 서버에서 실행되거나 SMS 사이트 데이터베이스에 액세스하는 일부 SMS 스크립트는 에이전트 없는 모드에서는 실행되지 않습니다. Microsoft SMS 2003 공급자 및 Microsoft SMS 사이트 데이터베이스 서버 컴퓨터 그룹의 모든 컴퓨터가 에이전트에서 관리되는 컴퓨터로 구성되었는지 확인합니다. 또한 이러한 스크립트 중 일부는 프록시 이벤트일 수 있으므로 이러한 에이전트가 프록시를 통해 연결할 수 있도록 구성되었는지 확인합니다.

파일럿 테스트 작업

  • 이전 버전에서 SMS 2003 Management Pack의 배포 또는 업그레이드 과정이 성공적으로 완료되었는지 확인합니다.
  • 성능 임계값의 Health Monitor 뷰를 사용하여 사용자 지정 임계값을 확인하고 사용자 환경에 맞게 편집합니다.
  • 성능 규칙이 Operations Manager 2007 성능에 주는 영향을 평가하기 위해 각 단계에서 성능 규칙을 사용하도록 설정합니다.
  • SMS 2003 컴퓨터 그룹이 SMS 2003을 실행하는 컴퓨터로 채워져 있는지 확인합니다.
  • 관련 규칙을 사용하도록 설정한 후 Operations Manager 2007의 뷰 및 보고서가 올바르게 작동하는지 확인합니다. 여기에는 SMS 처리 속도, 처리 합계 및 SMS 백로그와 관련된 뷰가 포함됩니다.
  • 기본적으로 다른 Management Pack과 관련된 일부 규칙은 사용하지 않도록 설정됩니다. 배포한 추가 Management Pack에 따라 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.
  • 기본적으로 에이전트의 CPU, 메모리 및 네트워크 리소스에 주는 영향을 최소화하기 위해 일부 성능 규칙은 사용하지 않도록 설정됩니다. 에이전트를 보다 세부적으로 모니터링하려는 경우 이러한 규칙을 사용하도록 설정할 수 있습니다.
  • SMS 2003 스크립트 실행 기반 이벤트가 생성되지 않는지 확인합니다. 이 이벤트는 일반적으로 스크립트의 액세스 권한에 문제가 있음을 나타냅니다.
  • DCAM 및 SQL Server의 크기가 프로덕션 부하에 적절한지 확인합니다.
  • 작업 프로세스 및 직원 요구 사항을 확인합니다.
  • 페이징 및 전자 메일 알림이 제대로 작동하는지 확인합니다.
  • Operations Manager 2007에서 사용하고 있는 권한이 올바르게 실행하는 데 적절한 권한인지 확인합니다.
  • Operations Manager 2007 에이전트가 LocalSystem 계정에서 실행되도록 지정되지 않은 경우 최소 보안 권한을 충족하는지 확인합니다. 자세한 내용은 이 가이드의 Operations Manager 2007 에이전트 배포 단원에 있는 "권한이 낮은 시나리오에서 실행할 수 있도록 에이전트 컴퓨터 구성" 단원을 참조하십시오.
  • SMS 서버 및 SMS 클라이언트 역할이 상태 뷰에 나타나는지 확인합니다. 이러한 각 역할을 호스팅하는 컴퓨터를 클릭하고 구성 요소가 인스턴스 창에 표시되는지 확인합니다.
  • 작업을 클릭하여 SMS Administrator 콘솔 작업이 작동하는지 확인합니다. 작업이 실행되지 않는 경우 SMS 2003 SP2 Administrator 콘솔이 설치되어 있고 로그온한 사용자가 로그오프한 다음 콘솔 설치를 완료한 후에 다시 로그온했는지 확인합니다.
  • 상태 뷰에서 SMS 서버 및 SMS 클라이언트를 클릭하고 역할 페이지에 적절한 역할과 속성 데이터가 표시되는지 확인합니다.
  • 모니터링 창에서 Microsoft Systems Management Server(SMS) 2003으로 이동하고 SMS 2003 사이트 계층 구조 다이어그램을 클릭합니다. Operations Manager 2007 에이전트가 해당 SMS 공급자에 로컬로 설치된 사이트에 대해 모든 사이트 시스템이 표시되는지 확인합니다. 사이트 시스템이 나타나지 않으면 SMS Administrator 콘솔에서 사이트 시스템이 사이트별로 검색되고 All Systems 컬렉션에 나타나는지 확인합니다.

파일럿 테스트를 완료한 후 SMS 2003 Management Pack을 내보내 Management Pack에서 변경한 내용을 백업합니다.

참고 항목

개념

Management Pack 사용자 지정
Operations Manager 2007 에이전트 배포
SMS 2003의 알려진 문제

기타 리소스

SMS 2003 Management Pack 문제 해결


Management Pack 사용자 지정

최적의 모니터링을 위해 조직의 비즈니스 필요에 따라 SMS 2003 Management Pack을 사용자 지정할 수 있습니다. 기존 규칙이 조직의 필요에 맞지 않는 경우 기존 규칙을 수정하거나 새 규칙을 만듭니다.

참고 SMS 2003 Management Pack을 변경하기 전에 항상 백업하십시오. Operations Manager 2007의 관리 팩 내보내기 마법사를 사용하면 편집 가능한 Management Pack을 백업할 수 있습니다.

사용자 지정할 수 있는 사항에는 다음이 포함됩니다.

  • 재정의를 사용하여 규칙을 사용 또는 사용하지 않도록 설정
  • 새 규칙 만들기
  • 경고 조건, 경고 심각도 및 경고 제거 수정
  • 규칙의 사용자 지정 임계값 설정. 모든 성능 임계값 규칙을 구성할 수 있습니다. 기본 임계값이 최적이 아닌 경우 불필요한 경고를 받거나, 임계값이 사용자 환경에 비해 너무 높게 설정되어 경고가 생성되지 않을 수 있습니다.
  • 재정의를 사용하거나 임계값의 경우 XML 뷰를 편집하여 수신함 모니터링 이벤트 규칙 임계값 및 폴링 간격 구성
  • 새 수신함 모니터링 이벤트 규칙 추가. 새 수신함 모니터링 규칙을 추가하려면 기본 Management Pack에서 새 규칙을 만든 다음 스크립트 입력 매개 변수(FileCountThreshold 및 InboxDirectoryName)와 일정에 대한 재정의를 만듭니다.
  • 재정의를 사용하여 성능 측정을 위한 폴링 간격 설정
  • 회사 기술 자료에 내용 추가
  • 규칙을 변경하거나 규칙에 새 응답을 추가하거나, 해당 경고에 대한 경고 처리 규칙을 추가하여 경고에 대한 응답 사용자 지정
  • 에이전트, Operations Manager 2007 실행 서버 및 많은 양의 데이터를 생성하고 성능 문제를 초래할 수 있는 데이터베이스에 대해 성능 측정 규칙을 사용하도록 설정. 잠재적인 성능 영향을 허용할지 여부를 사용자가 결정할 수 있도록 성능 측정 규칙은 기본적으로 사용하지 않도록 설정되어 있습니다. 성능 규칙을 검토하고 소규모 배치에서 이러한 규칙을 사용하도록 설정하면 데이터베이스의 크기를 포함하여 이러한 규칙이 Operations Manager 2007 성능에 주는 영향을 평가할 수 있습니다.
  • 수신함 모니터링 이벤트 규칙 및 관련 규칙의 매개 변수 설정. 재정의를 만들어 FileCountThreshold 및 InboxDirectoryName 스크립트를 수정합니다.
  • 사용자 환경에 적용할 수 있는 규칙 검토. 기본적으로 다른 Management Pack과 관련된 일부 규칙은 사용하지 않도록 설정됩니다. 배포한 추가 Management Pack에 따라 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.

Management Pack 사용자 지정과 Management Pack 사용자 지정 내용을 내보내는 방법에 대한 자세한 내용은 Operations Manager 2007 도움말의 "Operations Manager 2007의 관리 팩 정보" 및 "관리 팩 사용자 지정 설정을 내보내는 방법" 항목을 참조하십시오.

수신함 모니터링

Operations Manager 2007의 내보내기 마법사를 사용하면 기본 Management Pack을 추가로 변경하기 전에 변경 내용을 저장할 수 있습니다.

수신함 모니터링 규칙 구성

중앙, 주 및 보조 사이트 서버에 이러한 규칙을 배포하려면 Management Pack에서 SMS 사이트 서버 - 일반 규칙 그룹의 규칙을 기초로 새 규칙을 만들어야 합니다. 그런 다음 이러한 규칙을 사이트 서버의 적절한 처리 규칙 그룹에 할당하고 임계값을 수정한 다음 규칙을 사용하도록 설정합니다.

  • SMS 2003 수신함: 수신함 모니터링
  • SMS 2003 수신함: 수신함 모니터링 스크립트 오류
  • SMS 2003 수신함: 임계값이 초과됨

SMS 2003 수신함: 임계값이 초과됨 이벤트 처리 규칙은 SMS 2003: Monitor Inbox script error 스크립트에서 발생하는 이벤트를 모니터링합니다. 지정된 임계값 개수를 초과하는 각 수신함에 대해 고유한 경고가 생성됩니다.

이 스크립트의 기본 임계값 설정은 한 수신함에 10,000개의 파일입니다. 기본 Management Pack에서 이 스크립트나 임의의 스크립트 매개 변수에 대해 이 값의 재정의를 만들 수 있습니다. 지정된 값을 초과하면 “임계값이 초과됨” 이벤트가 발생합니다. 올바르게 작동하는 각 프로세스에 대해 서버의 일별 예상 부하를 계산한 다음 허용할 수 있는 버퍼 백분율을 추가하여 임계값 설정을 수정할 수 있습니다. 수신함 모니터링 규칙은 기본적으로 하루에 한 번씩 실행되며 01:00부터 시작하여 매일 15분씩 늦게 실행됩니다. 성능 영향을 최소화하려면 이 간격을 유지하거나 수신함 모니터링 규칙 간에 스크립트가 겹쳐 실행되는 것을 최소화할 수 있도록 조정하는 것이 좋습니다.

다음 표에서는 수신함 모니터링 규칙, 기본 임계값 및 SMS Executive 공급자에서 모니터링되는 수신함의 목록을 보여 줍니다.

SMS Executive 수신함 모니터링

수신함 모니터링 규칙 이름 | 기본 임계값 | 수신함 이름
SMS 2003 수신함: 수신함 모니터링 스크립트 오류 | 해당 없음 | 해당 없음
SMS 2003 수신함: 임계값이 초과됨 | 해당 없음 | 해당 없음
SMS 2003 수신함: auth\dataldr.box 모니터링 | 10000 | Inboxes\auth\dataldr.box
SMS 2003 수신함: auth\ddm.box 모니터링 | 10000 | Inboxes\auth\ddm.box
SMS 2003 수신함: auth\sinv.box 모니터링 | 10000 | Inboxes\auth\sinv.box
SMS 2003 수신함: compsumm.box\repl 모니터링 | 10000 | Inboxes\compsumm.box\repl
SMS 2003 수신함: dataldr.box 모니터링 | 10000 | Inboxes\dataldr.box
SMS 2003 수신함: ddm.box 모니터링 | 10000 | Inboxes\ddm.box
SMS 2003 수신함: despoolr.box\receive 모니터링 | 10000 | Inboxes\despoolr.box\receive
SMS 2003 수신함: offermgr.box\INCOMING 모니터링 | 10000 | Inboxes\offermgr.box\INCOMING
SMS 2003 수신함: offersum.box\repl 모니터링 | 10000 | Inboxes\offersum.box\repl
SMS 2003 수신함: replmgr.box\incoming 모니터링 | 10000 | Inboxes\replmgr.box\incoming
SMS 2003 수신함: schedule.box\outboxes\LAN 모니터링 | 10000 | Inboxes\schedule.box\outboxes\LAN
SMS 2003 수신함: statmgr.box\statmsgs 모니터링 | 10000 | Inboxes\statmgr.box\statmsgs
SMS 2003 수신함: swmproc.box\usage 모니터링 | 10000 | Inboxes\swmproc.box\usage

수신함 모니터링 이벤트 규칙 재정의 절차

수신함 모니터링 이벤트 규칙을 재정의하려면 먼저 Operations Manager 2007 사이트에서 Microsoft SMS 2003 Site Servers 유형의 SMS 2003 사이트 서버 개체를 검색해야 합니다.

수신함 모니터링 이벤트 규칙을 재정의하려면

  1. Operations Manager 2007 작업 콘솔에서 제작 단추를 선택합니다.

  2. 제작 / 관리 팩 개체 / 규칙을 찾습니다.

  3. Microsoft SMS 2003 사이트 서버의 범위를 지정합니다.

  4. 적절한 SMS 2003 수신함 모니터링 이벤트 규칙(예: SMS 2003 Inbox: Moinitor schedule box\requests)을 마우스 오른쪽 단추로 클릭하고 재정의를 선택한 다음 규칙 재정의를 선택하고 다음 유형의 모든 개체: Microsoft SMS 2003 Site Servers를 클릭합니다.

  5. 재정의 속성에서 사용 재정의 확인란을 선택하고 재정의 설정을 True로 설정합니다.

  6. 재정의 속성에서 FileCountThreshold 재정의 확인란을 선택하고 재정의 설정을 원하는 임계값으로 설정합니다.

  7. 확인을 클릭합니다. 다시 확인을 클릭합니다. 수정된 임계값이 서버에 배포됩니다.

성능 카운터 임계값 모니터링 편집 절차

성능 카운터 임계값 모니터링을 편집하려면 다음 단계를 수행하십시오.

성능 카운터 임계값 모니터링을 편집하려면

  1. Operations Manager 2007 작업 콘솔에서 제작 단추를 선택합니다.

  2. 제작 / 관리 팩 개체 / 모니터를 찾습니다.

  3. 범위를 SMS 서버로 변경합니다.

  4. SMS 서버 / Entity Health / MOM 2005 Computer Role Health를 찾은 다음 SS(사이트 서버의 경우) 등의 적절한 컴퓨터 역할을 선택합니다.

  5. 편집할 성능 임계값 모니터링 규칙을 두 번 클릭합니다. Performance Threshold Properties 대화 상자가 열립니다.

  6. 구성 탭을 선택합니다.

  7. 편집…을 클릭합니다. XML 구성 대화 상자가 열립니다.

  8. XML 텍스트에서 수정할 임계값을 편집합니다.

    • <CriticalErrorExpression>에 중첩된 <ValueExpression>을 지정하여 중요한 오류 임계값을 변경합니다.
    • <WarningExpression>에 중첩된 <ValueExpression>을 지정하여 경고 임계값을 변경합니다.

  9. 확인을 클릭합니다. 다시 확인을 클릭합니다. 수정된 임계값이 서버에 배포됩니다.

참고 항목

개념

Management Pack 테스트 및 파일럿 테스트
지원되는 SMS 구성
Management Pack 모니터링 시나리오

기타 리소스

SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003 Management Pack의 운영 작업 수행

모든 경고를 신속하게 검토하고 해결하여 중요하거나 중요할 수 있는 특성을 식별하는 것이 좋습니다. 그 밖에도 다른 작업을 사용자 환경에 따라 정기적으로 수행해야 합니다. 중요한 많은 문제는 경고를 발생시키지 않지만 여전히 정기적으로 확인해야 합니다. Microsoft® Systems Management Server(SMS) 2003 Management Pack에는 시간 경과에 따라 데이터를 표시하고 문제를 나타내는 패턴을 보여 주는 뷰와 보고서가 포함되어 있습니다. 문제로 인해 경고가 생성되기 전에 뷰와 보고서를 검토하여 문제를 해결해야 합니다.

이 단원에 지정된 대로 일별, 주별 및 월별 작업을 수행하되 이러한 작업을 수행하는 빈도는 특정 사용자 환경에 맞게 조정해야 합니다.

이 섹션에서

SMS 2003의 일별 작업

SMS 2003의 주별 작업

SMS 2003의 월별 작업

SMS 2003 Administrator 콘솔 작업

참고 항목

개념

Management Pack 모니터링 시나리오
SMS 2003 Management Pack 배포

기타 리소스

System Management Server 2003 Management Pack 개요
SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003의 일별 작업

다음 작업은 매일 수행하는 것이 좋습니다.

  • 열린 모든 경고 검토
  • 컴퓨터 그룹 구성원 자격 검토
  • 모든 Operations Manager 2007 에이전트가 Operations Manager 2007 서버와 통신하고 있는지 확인
  • 성능 백로그 검토
  • 성능 처리 속도 검토
  • Operations Manager 2007 에이전트 및 서버 성능 검토
  • 알림 그룹 구성원 자격 또는 이벤트 처리 규칙 알림 그룹 검토
  • SMS 2003 사이트 백업 검토
  • 이벤트 검토(선택적)

열린 모든 경고 검토

SMS 2003 Management Pack의 경고는 다음과 같은 경고 설명 형식으로 표시됩니다.

$Computer$ <Rule Name>

$Description$

Event details

Operations Manager 2007의 모든 경고를 검토하여 경고가 제때에 처리되도록 해야 합니다. 다음 중 원하는 방법을 사용하여 열린 경고를 검토할 수 있습니다.

  • 작업 콘솔에서 모니터링 단추를 클릭하고 Microsoft Systems Management Server(SMS) 2003을 확장한 다음 경고를 클릭합니다.
  • 작업 콘솔에서 모니터링 단추를 클릭하고 Microsoft Systems Management Server(SMS) 2003을 확장한 다음 일반을 클릭합니다. 최근 72시간 동안 새로 발생한 경고를 선택합니다.
  • 컴퓨터 및 그룹을 클릭하면 컴퓨터 또는 컴퓨터 그룹별로 경고를 볼 수 있습니다. 경고 심각도별로 요약하여 표시하려면 조사할 SMS 2003 컴퓨터 그룹을 마우스 오른쪽 단추로 클릭하고 보기를 선택한 다음 경고를 클릭합니다.
  • 상태 뷰를 통해 경고를 볼 수 있습니다. 상태 뷰에는 컴퓨터 목록과 심각도가 가장 높은 경고가 표시됩니다. 컴퓨터를 두 번 클릭하면 해당 컴퓨터의 현재 경고 목록을 볼 수 있습니다.
  • 다이어그램 뷰를 통해 경고를 볼 수 있습니다. SMS 2003 계층 구조 다이어그램 뷰에는 SMS 2003 계층 구조가 시각적으로 표시됩니다. 각 컴퓨터에는 심각도가 가장 높은 경고를 나타내는 상태 주석이 표시됩니다. 컴퓨터를 두 번 클릭하면 해당 컴퓨터의 현재 경고 목록을 볼 수 있습니다.

다음 순서로 모든 새 경고를 검토하는 것이 좋습니다.

  1. SMS 2003 핵심 서비스 경고
  2. SMS 2003 종속 서비스 경고
  3. SMS 2003 Site System Status Summarizer 기반 경고
  4. SMS 2003 관리 지점 상태 경고
  5. SMS 2003 상태 메시지 기반 경고
  6. SMS 2003 구성 요소 경고
  7. SMS 2003 백로그 경고
  8. SMS 2003 수신함 모니터링 경고
  9. SMS 2003 SMS Site Backup 서비스 실패 경고
  10. SMS 2003 프로그램 실패 경고

컴퓨터 그룹 구성원 자격 검토

Operations Manager 2007을 사용하여 컴퓨터 그룹 구성원 자격을 확인할 수 있습니다.

  • 작업 콘솔에서 제작 단추를 클릭하고 그룹을 클릭한 다음 적절한 SMS 2003 컴퓨터 그룹을 마우스 오른쪽 단추로 클릭합니다. 표시된 각 컴퓨터 그룹에 올바른 컴퓨터가 포함되어 있는지 확인합니다.

에이전트가 Operations Manager 2007 서버와 통신하는지 확인

에이전트와 모니터링 인프라 간의 통신에 실패할 경우 사용자에게 경고가 표시되지 않습니다. 에이전트와 Operations Manager 2007을 실행하는 서버가 통신하고 있는지 확인하려면 가용성 보고서를 실행합니다. 자세한 내용은 Operations Manager 2007 도움말의 "Operations Manager 2007에서 가용성 보고서를 만드는 방법" 항목을 참조하십시오.

성능 백로그 및 성능 처리 속도 검토

성능 백로그와 성능 처리 속도는 일별 추세를 파악하고 SMS 계층 구조에서 발생하는 사항을 이해하는 데 매우 유용합니다. 성능 백로그와 성능 처리 속도는 Operations Manager 2007에서 볼 수 있습니다.

성능 백로그를 검토하려면

성능 백로그를 검토하려면 다음 단계를 수행하십시오.

성능 백로그를 검토하려면

  1. 작업 콘솔에서 모니터링 단추를 클릭하고 Microsoft Systems Management Server(SMS) 2003을 확장합니다.

  2. 성능을 확장하고 백로그를 확장합니다. 그런 다음 적절한 구성 요소 하위 폴더를 클릭합니다. 카운터 옵션을 사용하여 표시된 데이터인 컴퓨터 수를 줄이거나 관심 있는 컴퓨터만 선택합니다.

성능 처리 속도를 검토하려면

성능 처리 속도를 검토하려면 다음 단계를 수행하십시오.

성능 처리 속도를 검토하려면

  1. 작업 콘솔에서 모니터링 단추를 클릭하고 Microsoft Systems Management Server(SMS) 2003을 확장합니다.

  2. 성능을 확장하고 백로그를 확장합니다. 그런 다음 적절한 구성 요소 하위 폴더를 클릭합니다. 카운터 옵션을 사용하여 표시된 데이터인 컴퓨터 수를 줄이거나 관심 있는 컴퓨터만 선택합니다.

SMS 2003 Site Backup 서비스 모니터링

SMS Site Backup 서비스 유지 관리 작업을 사용할 수 있도록 설정하고 엔터프라이즈 환경에서 필요한 대로 백업 일정을 세워야 합니다. SMS Site Backup 서비스는 시작 시 먼저 SMS_EXECUTIVE, SMS_SQL_MONITOR, SMS_SITE_COMPONENT_MANAGER를 비롯한 모든 SMS 서비스를 중지합니다. 다음과 같은 경우에는 SMS Site Backup 프로세스에서 런타임 백업을 지원하지 않습니다.

  • SMS 설치 폴더의 일부를 백업 내보내기 경로에 복사하고 있는 경우
  • 다양한 SMS 레지스트리 값을 백업하고 있는 경우
  • Microsoft SQL Server™를 실행하는 서버에서 SMS 사이트 데이터베이스를 백업하고 있는 경우

백업이 완료되면 SMS Site Backup 서비스에서 SMS 서비스를 다시 시작합니다. 이러한 서비스 중지 및 시작은 백업 프로세스에서 정상적인 과정이며 중요한 오류를 나타내는 것이 아닙니다. SMS Site Backup 서비스를 실행할 때는 이러한 서비스를 중지할 경우 발생할 수 있는 경고가 제거됩니다. 이러한 서비스의 중지 및 시작뿐 아니라 SMS Site Backup 서비스의 중지 및 시작도 연결할 수 있습니다. 이렇게 하려면 다음 규칙을 사용해야 합니다. 이러한 규칙은 SMS Site Backup 서비스가 시작되거나 중지될 때 정보 제공용 경고를 발생시킵니다.

  • SMS 2003 서비스 실행 중지: SMS_SITE_BACKUP
  • SMS 2003 서비스 실행 시작: SMS_SITE_BACKUP

SMS Site Backup 서비스가 시작되지 않거나 예기치 않게 중지되면 다음 경고가 발생합니다.

  • SMS 2003 서비스 오류: SMS_SITE_BACKUP이 예기치 않게 종료됨
  • SMS 2003 서비스 오류: SMS_SITE_BACKUP이 시작 시 멈춤
  • SMS 2003 서비스 오류: SMS_SITE_BACKUP을 시작하지 못함
  • SMS 2003 서비스 오류: SMS_SITE_BACKUP이 로그온할 수 없음
  • SMS 2003 서비스 오류: SMS_SITE_BACKUP을 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

서비스가 예기치 않게 종료되었음을 나타내는 경고가 표시되면 중지된 서비스가 모두 다시 시작되었는지 확인하십시오. 이러한 서비스가 다시 시작되기 전에 SMS Site Backup 서비스가 종료되었을 수 있습니다.

백업 프로세스의 성공/실패 여부를 표시하기 위해 다음 상태 메시지 경고가 생성됩니다.

  • SMS 2003 상태: 사이트 백업이 성공적으로 완료됨
  • SMS 2003 상태: 사이트 백업에 실패함

액세스 문제, 디스크 공간 부족, 특정 서비스 시작 또는 중지 오류 또는 SQL Server 작업의 오류가 있으면 백업이 실패할 수 있습니다.

이벤트 검토

이벤트는 중요하지 않은 오류를 나타내며 이를 통해 Operations Manager 2007 에이전트의 작동 방식을 살펴볼 수 있으므로 정기적으로 이벤트를 검토해야 합니다.

이벤트를 검토하려면

이벤트를 검토하려면 다음 단계를 수행하십시오.

이벤트를 검토하려면

  1. 작업 콘솔에서 모니터링 단추를 클릭합니다.

  2. Microsoft Systems Management Server(SMS) 2003을 확장하고 이벤트를 클릭합니다.

참고 항목

개념

SMS 2003의 주별 작업
SMS 2003의 월별 작업
SMS 2003 Administrator 콘솔 작업

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003의 주별 작업

매일 수행하는 작업 외에도 매주 다음 작업을 수행해야 합니다.

  • 보고서를 검토합니다. SMS 2003 Management Pack에 포함된 보고서 목록은 이 가이드의 SMS 2003의 보고서 단원을 참조하십시오.
  • 지난 주의 잠재적 문제 및 추세에 대한 경고, 이벤트 및 성능을 검토합니다.
  • 필요한 경우 Operations Manager 2007 에이전트 하트비트 간격, 서비스 모니터링 상태 검사 간격, 에이전트 관리자 하트비트 검사 간격, 검색 간격, 데이터베이스 그루밍 매개 변수와 같은 Operations Manager 2007 구성 설정을 조정합니다.
  • SMS 사이트의 백업 기록을 검토합니다.
  • SMS 2003용 Operations Manager 2007 구성 그룹의 백업 기록을 검토합니다.
  • SQL Server 데이터베이스 및 로그를 검토합니다.
  • SMS 2003 가용성 보고서를 실행하여 SMS 서버 및 해당 구성 요소의 가용성을 확인합니다.
  • SMS 2003 계층 구조 다이어그램을 사용하여 SMS 계층 구조를 확인합니다.

참고 항목

개념

SMS 2003의 일별 작업
SMS 2003의 월별 작업
SMS 2003 Administrator 콘솔 작업

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003의 월별 작업

매일 및 매주 수행하는 작업 외에도 매월 다음 범주의 데이터를 검토해야 합니다.

가장 일반적인 경고 및 이벤트

  • 가장 일반적인 경고
  • 가장 일반적인 이벤트
  • 규칙 그룹별로 가장 일반적인 경고 및 이벤트
  • SMS 2003 구성 요소별로 가장 일반적인 경고 및 이벤트
  • SMS 2003 기능별로 가장 일반적인 경고 및 이벤트

이러한 경고 및 이벤트 수를 줄이기 위한 작업 계획을 세워야 합니다.

SMS 백로그 모니터링

  • 다양한 사이트 시스템의 백로그 추세와 관련된 보고서를 살펴봅니다.

SMS 백로그 추세

  • 백로그 관련 보고서를 검토하여 백로그 수가 오랫동안 증가하는 추세에 있거나 SMS 사이트 시스템의 SLA(서비스 수준 계약)에 영향을 주는 허용되지 않는 수준의 백로그가 있지 않은지 확인합니다.

SMS 성능 추세: 합계 및 처리 속도

  • 검색 데이터 기록
  • 하드웨어 인벤토리
  • 소프트웨어 인벤토리
  • 소프트웨어 미터링
  • 상태 메시지

일반적인 시스템 성능

  • 디스크 사용량
  • 메모리 사용량
  • 프로세서 사용량

SMS 서비스 가용성

  • SMS_EXECUTIVE
  • SMS Agent Host 서비스
  • SMS Client 서비스
  • SMS_REPORTING_POINT
  • SMS_SERVER_LOCATOR_POINT
  • SMS_SQL_MONITOR
  • SMS_SITE_COMPONENT_MANAGER

SMS 가용성

  • SMS 2003 가용성 보고서를 실행하여 SMS 서버 및 SMS 구성 요소의 가용성을 확인합니다.

참고 항목

개념

SMS 2003의 일별 작업
SMS 2003의 주별 작업
SMS 2003 Administrator 콘솔 작업

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003 Administrator 콘솔 작업

SMS Administrator 콘솔 작업을 수행하려면 Operations Manager 2007 작업 콘솔과 같은 컴퓨터에 Microsoft Systems Management Server(SMS) 2003 SP2 이상의 Administrator 콘솔을 설치해야 합니다. SMS Administrator 콘솔을 설치한 후에는 Windows에서 로그오프했다가 다시 로그온해야 작업 기능을 사용할 수 있습니다.

Management Pack 작업

작업 | 설명
SMS Administrator 콘솔 | 현재 선택된 컴퓨터에 대한 SMS Administrator 콘솔을 엽니다. 이 작업은 SMS 사이트 서버 역할을 호스팅하는 컴퓨터에 적용됩니다.
모든 SMS 상태 메시지 | 컴퓨터의 사이트 서버를 확인하고 MMC 창을 연 다음 상태 메시지 쿼리를 실행하여 현재 선택된 컴퓨터와 연관된 모든 상태 메시지를 반환합니다. 이 작업은 모든 시스템에 적용됩니다.
SMS 서비스 관리자 | 현재 선택된 컴퓨터에 대한 SMS 서비스 관리자를 엽니다. 이 작업은 SMS 사이트 서버 역할을 호스팅하는 컴퓨터에 적용됩니다.
SMS 리소스 탐색기 | 컴퓨터의 사이트 서버를 확인하고 MMS 창을 연 다음 현재 선택된 컴퓨터의 데이터를 이 창의 SMS 리소스 탐색기에 표시합니다. 이 작업은 모든 시스템에 적용됩니다.

참고 항목

개념

SMS 2003의 일별 작업
SMS 2003의 주별 작업
SMS 2003의 월별 작업

기타 리소스

SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003 Management Pack 문제 해결

다음과 같은 여러 가지 방법으로 제품 문제를 해결할 수 있습니다.

  • Operations Manager 2007이 올바르게 설치되었는지 확인합니다.
  • Operations Manager 2007 구성 설정이 올바른지 확인합니다.
  • 모든 Microsoft® Systems Management Server(SMS) 시스템이 Operations Management 정보로 구성되어 있는지 확인합니다.
  • 관리되는 모든 SMS 공급자 및 SMS 사이트 데이터베이스 컴퓨터에 Operations Manager 2007 에이전트가 설치되어 있으며 해당 컴퓨터가 다른 컴퓨터에 프록시를 통해 연결할 수 있도록 설정되어 있는지 확인합니다.
  • Management Pack 가져오기가 완료되고 성공되었는지 확인합니다.
  • 규칙 및 관련 경고와 같은 관련된 항목이 사용하도록 설정되어 있는지 확인합니다.
  • 컴퓨터 그룹이 올바른 컴퓨터로 채워졌는지 확인합니다. 뷰를 사용하여 이 검사를 수행할 수 있습니다.
  • 하트비트 오류 경고가 없는지 확인합니다.
  • 하트비트 간격이 올바르게 설정되고 Operations Manager 2007 에이전트 컴퓨터에 규칙이 전파되었는지 확인합니다.
  • WMI(Windows Management Instrumentation), World Wide Web Publishing 서비스, IIS(인터넷 정보 서비스) Admin Service, BITS(Background Intelligent Transfer Service) 및 MSSQLServer를 비롯한 종속 서비스가 SMS 2003 사이트 시스템에 올바르게 설치되어 실행 중인지 확인합니다.
  • 과도한 이벤트 생성, 올바르지 않은 구문 또는 너무 긴 스크립트 실행 등으로 인해 Operations Manager 2007에서 자동으로 사용하지 않도록 설정된 규칙이 없는지 확인합니다.
  • 모든 성능 카운터가 올바르게 설치되었는지 확인합니다.

이 섹션에서

SMS 2003의 알려진 문제

참고 항목

개념

Management Pack 모니터링 시나리오
SMS 2003 Management Pack 배포

기타 리소스

System Management Server 2003 Management Pack 개요
SMS 2003 Management Pack의 운영 작업 수행
Microsoft System Management Server 2003 Management Pack용 참조


SMS 2003의 알려진 문제

Systems Management Server 2003 Management Pack for Operations Manager 2007에는 다음과 같은 알려진 문제가 있습니다.

유지 관리 모드 및 토폴로지 뷰를 실행하려면 SMS 2003 SP3이 필요하다

WMI 서비스를 중지하는 타사 소프트웨어를 설치할 때 SMS와 충돌할 수 있다

WMI 모니터링

SMS 작업이 SMS 2003 관리자 콘솔을 설치하는 데 사용된 사용자 컨텍스트에서만 실행된다

SMS 관리자 콘솔이 SMS 보조 사이트와 같은 컴퓨터에 설치된 경우 SMS 2003 Management Pack에서 SMS 보조 사이트를 감지할 수 없다

시스템이 다시 시작된다

SMS 2003의 SMS 상태 메시지 모니터 스크립트

SMS 2003의 Monitor Site Summarizer 스크립트의 실행 간격이 기본 Site System Status Summarizer 간격과 차이가 난다

발신자 연결을 모니터링하는 상태 메시지 규칙이 발신자 작동에 의존한다

BITS 모니터링이 기본적으로 사용되지 않는다

응용 프로그램 공급자 경로가 기본적으로 일부 SMS 사이트 서버에서는 유효하지 않을 수 있는 C:\SMS\Logs로 설정된다

유지 관리 모드 및 토폴로지 뷰를 실행하려면 SMS 2003 SP3이 필요하다

Operations Manager 2007에서 유지 관리 모드를 사용하거나 사이트 토폴로지를 보려면 SMS 2003 사이트 서버에 SMS 2003 SP3이 설치되어 있어야 합니다. 자세한 내용은 지원되는 SMS 구성을 참조하십시오.

WMI 서비스를 중지하는 타사 소프트웨어를 설치할 때 SMS와 충돌할 수 있다

WMI 서비스에 액세스하는 타사 소프트웨어를 설치할 때 SMS 2003 Management Pack과 충돌할 수 있습니다. 대부분의 Management Pack 스크립트는 WMI를 사용하여 레지스트리에 액세스하며 WMI 서비스를 다시 시작할 수 있습니다. WMI 서비스가 사용하도록 설정되어 있고 이를 시작할 수 있으면 COM(구성 요소 개체 모델)에서 아무 문제 없이 WMI를 다시 시작할 수 있습니다.

타사 소프트웨어가 중지되지만 설치 또는 업그레이드 중에 WMI를 사용할 수 없게 하지는 않을 경우 WMI 스크립트의 자동 재시작 기능은 타사 소프트웨어 설치의 성공 여부에 영향을 줄 수 있습니다. 이로 인해 설치 프로그램에서 먼저 WMI 서비스를 사용할 수 없게 설정하지 않을 경우 WMI 또는 WMI 공급자의 업그레이드에 문제가 발생할 수 있습니다. 이 문제는 WMI의 모든 클라이언트에 해당됩니다.

WMI 모니터링

  • Windows NT® 시스템 이벤트 기반의 다음 규칙은 서비스 제어 관리자에서 예기치 않은 서비스 오류에 대해 생성된 이벤트를 기록합니다. 이러한 규칙에 대한 알려진 운영 체제 제한은 없습니다.
  • SMS 2003 종속 서비스 오류: Windows Management Instrumentation이 예기치 않게 종료됨.
  • SMS 2003 종속 서비스 오류: Windows Management Instrumentation이 시작 시 멈춤.
  • SMS 2003 종속 서비스 오류: Windows Management Instrumentation이 시작되지 않음.
  • SMS 2003 종속 서비스 오류: Windows Management Instrumentation이 로그온할 수 없음.
  • SMS 2003 종속 서비스 오류: Windows Management Instrumentation을 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

SMS 작업이 SMS 2003 관리자 콘솔을 설치하는 데 사용된 사용자 컨텍스트에서만 실행된다

이 문제는 SMS 관리자 콘솔 설치 시 SMS_UI_PATH 환경 변수가 시스템 환경 변수가 아니라 사용자 환경 변수로 만들어졌기 때문에 발생합니다. 이 문제를 해결하려면 모든 운영자와 관리자가 오류 없이 작업을 호출할 수 있도록 SMS_UI_PATH의 이름 및 값을 복사하고 위의 변수를 시스템 환경 변수로 정의합니다.

SMS 관리자 콘솔이 SMS 보조 사이트와 같은 컴퓨터에 설치된 경우 SMS 2003 Management Pack에서 SMS 보조 사이트를 감지할 수 없다

SMS 보조 사이트 서버로도 사용되는 컴퓨터에 Systems Management Server 2003 관리자 콘솔을 설치하면 SMS 2003 Management Pack에서 해당 서버를 SMS 보조 사이트 서버로 식별하지 못합니다.

이 문제를 해결하려면 SMS 보조 사이트 서버에 SMS 관리자 콘솔을 설치할 때 레지스트리 값 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type을 4에서 2로 변경해야 합니다.

시스템이 다시 시작된다

시스템이 다시 시작될 경우 단 몇 개의 서비스 중지 경고만 나타날 수 있습니다. 시스템이 다시 시작되었음을 나타내는 이벤트나 경고는 없습니다. 예상한 시스템 종료나 예상치 않은 시스템 종료를 감지하기 위한 최상의 방법은 시스템 재시작 시 경고를 생성하는 규칙이 포함된 Microsoft Windows Server Base Operating System Management Pack을 설치하는 것입니다. 시스템 재시작이 발생했는지 여부를 확인하기 위한 다른 방법은 SMS 로그, Operations Manager 2007 NT 이벤트 로그, Windows NT 이벤트 로그 및 Operations Manager 2007의 에이전트 통신에 대한 이벤트를 검사하는 것입니다.

SMS 2003의 SMS 상태 메시지 모니터 스크립트

SMS 상태 메시지 표의 메시지 수가 4,294,967,296개를 초과하면 레코드 ID는 0부터 다시 시작됩니다. SMS 2003의 SMS 상태 메시지 모니터 스크립트에는 레코드 ID가 0부터 다시 시작될 경우 이를 감지하는 메커니즘이 없습니다. 현재 이 스크립트는 마지막으로 처리한 상태 메시지의 레코드 ID에서 정방향으로만 검색합니다. 따라서 레코드 ID가 다시 시작되면 Management Pack에서 새 상태 메시지를 검색할 수 없습니다.

사이트 서버에서 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 레지스트리 키의 Next Status Message Record ID 레지스트리 값에 주의하십시오. 이 값은 SQL StatusMessages 테이블에 삽입되는 다음 레코드 ID입니다. 이 값이 LastRecordID 값보다 작으면 StatusMessages 테이블은 다시 순환하고 다시 시작됩니다. 스크립트는 Next Status Message Record ID 레지스트리 값이 VarSet 파일의 LastRecordID 값보다 커질 때까지 메시지를 다시 처리하지 않습니다.

사이트 서버에서 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 레지스트리 키를 정기적으로 모니터링하여 다음 상태 메시지의 레코드 ID를 확인해야 합니다. 소규모 조직이나 SMS 계층 구조에서 하위에 있는 소규모 사이트에서는 이 레지스트리 키를 두세 달마다 확인해야 합니다. 대규모 조직이나 여러 개의 자식 사이트가 있는 사이트에서는 이 레지스트리 키를 매달 확인해야 합니다. 값이 4,294,967,296에 가까울수록 이 레지스트리 키를 보다 자주 모니터링합니다. 레코드 ID가 0으로 다시 설정된 후에는 사이트에 대해 SMS 사이트 데이터베이스 서버를 실행하는 컴퓨터에서 상태 메시지 모니터링을 차단 해제해야 합니다. SMS 사이트 데이터베이스의 위치는 SMS를 설치할 때 지정합니다.

레지스트리 키 모니터링을 자동화하는 한 가지 방법은 컴퓨터 특성 및 컴퓨터 그룹을 만들어 이 임계값에 근접하는 컴퓨터를 모니터링하는 것입니다.

구성 그룹의 모든 SMS 사이트 데이터베이스를 찾으려면

  1. 작업 콘솔에서 제작 단추를 클릭합니다.
  2. 결과 창에서 Microsoft Systems Management Server(SMS) 2003을 마우스 오른쪽 단추로 클릭하고 그룹 구성원 보기를 선택합니다.

상태 메시지 모니터링을 차단 해제하려면

  1. SMS 사이트 데이터베이스 역할을 호스팅하는 컴퓨터의 Windows Temp 폴더에서 SMS 2003 Monitor SMS Status Messages.VarSet 파일을 엽니다. LastRecordID_[SMSDatabaseName] 항목은 스크립트에서 처리한 SQL StatusMessages 테이블의 최근 상태 메시지를 나타내는 레코드 ID입니다.
  2. SMS 사이트 데이터베이스 역할을 호스팅하는 컴퓨터의 SMS 2003 Monitor SMS Status Messages.VarSet 파일에서 적절한 사이트에 대한 LastRecordID_[SMSDatabaseName] 값을 Next Status Message Record ID 레지스트리 값에서 1을 뺀 값으로 변경합니다. 결과 값이 4,294,967,296이면 해당 값을 0으로 설정하고 파일을 저장합니다.

SMS 2003의 Monitor Site Summarizer 스크립트의 실행 간격이 기본 Site System Status Summarizer 간격과 차이가 난다

SMS 2003의 사이트 시스템 요약 작성기 모니터 스크립트가 실행되는 간격은 Site System Status Summarizer 폴링 간격과 매시간 10분씩 차이가 납니다. SMS 관리자 콘솔을 통해 Site System Status Summarizer 일정을 구성할 수 있지만 이 폴링 간격은 변경할 수 없고 다른 유지 관리 작업의 간격만 변경할 수 있습니다. SMS 2003의 사이트 시스템 요약 작성기 모니터 스크립트는 60분마다 예약, 00:10에 동기화 시간 제한 이벤트 공급자를 통해 실행됩니다. 10분의 시간차가 있으므로 Site System Status Summarizer가 주기를 완료할 수 있는 시간이 충분합니다. 이 시간이 충분하지 않으면 시간을 늘려야 합니다. 그렇지 않으면 사이트 시스템 요약 작성기가 주기를 완료하기 전에 스크립트가 종료됩니다. 이 경우 이전 사이트 시스템 상태가 보고될 수 있습니다.

발신자 연결을 모니터링하는 상태 메시지 규칙이 발신자 작동에 의존한다

발신자가 부모 사이트에 연결할 수 없는 경우 SMS 계층 구조의 상위로 상태 메시지가 전달되지 않고 Management Pack에서 해당 상태 메시지에 대한 경고를 생성하지 않습니다. 이는 SMS 2003 Monitor Status Message 스크립트를 실행하지 않는 보조 사이트의 경우에 특히 중요합니다. 발신자 연결을 모니터링하는 다음 상태 메시지 규칙은 발신자 작동에 의존하며 기본적으로 사용할 수 없도록 설정되어 있습니다.

  • SMS 2003 상태: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 상태: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 상태: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
참고
이러한 모든 규칙은 기본적으로 사용할 수 없도록 설정되어 있습니다. 이러한 규칙을 사용하려면 각 SMS 사이트 데이터베이스 서버나 최소한 중앙 사이트가 관리되는 컴퓨터여야 합니다.

병렬 모니터링 방법은 응용 프로그램 로그 공급자인 SMS 2003 발신자 로그를 기반으로 하여 제공되었습니다. 이러한 규칙은 기본적으로 사용하도록 설정되어 있습니다. 이러한 규칙을 사용하지 않을 경우 위의 관련 상태 메시지 규칙을 사용하는 것이 좋습니다. 두 규칙 집합을 모두 사용하면 중복 경고가 발생하므로 둘을 모두 사용하지 마십시오. 이러한 이벤트 또는 경고 규칙을 통합하여 활성 상태인 상태 메시지 및 구성 요소 규칙을 모두 처리할 수 있는 방법은 없습니다.

  • SMS 2003 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음

이러한 규칙이 작동하려면 규칙을 수정하여 SMS 로그 파일 경로를 지정해야 합니다. 또한 발신자가 있는 각 SMS 서버가 관리되는 컴퓨터여야 합니다.

BITS 모니터링이 기본적으로 사용되지 않는다

BITS(Background Intelligent Transfer Service) 서비스는 SMS 고급 클라이언트에서 요청할 때 시작되므로 SMS 2003 Management Pack에서 다음 규칙은 기본적으로 사용되지 않습니다.

  • SMS 2003 종속 서비스 실행 중: BITS(Background Intelligent Transfer Service)

서비스가 자동으로 시작되도록 구성된 경우에는 이 규칙을 사용해야 합니다.

BITS 서비스의 문제를 모니터링하고 SMS 에이전트 호스트에서 필요할 때 BITS 서비스를 시작할 수 없는 경우 이를 보고하기 위해 다음 규칙은 기본적으로 사용하도록 설정되어 있습니다.

  • SMS 2003 서비스 오류: BITS(Background Intelligent Transfer Service)가 예기치 않게 종료됨
  • SMS 2003 서비스 오류: BITS(Background Intelligent Transfer Service)가 시작 시 멈춤
  • SMS 2003 서비스 오류: BITS(Background Intelligent Transfer Service)를 시작하지 못함
  • SMS 2003 서비스 오류: BITS(Background Intelligent Transfer Service)가 로그온할 수 없음

SMS 2003 서비스 오류: BITS(Background Intelligent Transfer Service)를 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

응용 프로그램 공급자 경로가 기본적으로 일부 SMS 사이트 서버에서는 유효하지 않을 수 있는 C:\SMS\Logs로 설정된다

응용 프로그램 로그 공급자를 사용하여 C:\SMS\Logs의 SMS 로그 파일을 모니터링하는 구성 요소 규칙에는 다음 네 가지가 있습니다.

  • SMS 2003 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
  • SMS 2003 구성 요소: 배포 관리자가 패키지를 처리하지 못함

발신자 규칙은 기본적으로 사용하도록 설정되어 있는 반면 배포 관리자 규칙은 기본적으로 사용하지 않도록 설정되어 있습니다. C 드라이브 이외의 드라이브에 SMS를 설치했거나 기본 로그 저장 폴더를 수정한 경우에는 이 규칙을 사용하기 전에 수정해야 합니다. 올바른 폴더에서 로그 파일을 검색하도록 이 규칙을 수정하지 않으면 경고에서 찾으려고 한 정보가 반환되지 않습니다.

올바른 경로를 가리키도록 규칙을 수정할 때는 로그 파일 경로를 입력할 수도 있고 환경 변수를 만든 다음 해당 변수를 사용하도록 규칙을 수정할 수도 있습니다. 경로를 입력할 때 해당 경로는 이 규칙의 영향을 받는 모든 사이트 서버에서 사용할 수 있는 경로여야 합니다. 주 사이트 서버용과 보조 사이트 서버용으로 각기 다른 두 개의 경로가 별도로 있는 경우 다음 단계를 따릅니다.

대체 로그 파일 경로를 사용하도록 구성 요소 규칙 xml을 수정하려면

  1. Operations Manager 2007 작업 콘솔에서 제작 단추를 클릭하고 관리 팩 개체를 확장한 다음 규칙을 클릭합니다.

  2. 세부 정보 창에서 수정할 규칙을 마우스 오른쪽 단추로 클릭하고 속성을 선택합니다.

  3. 구성 탭을 클릭합니다.

  4. 응답 창에서 xml을 편집할 응답을 선택합니다.

  5. 편집... 단추를 클릭합니다. GenerateAlert - 속성 대화 상자가 열립니다.

  6. GenerateAlert - 속성 대화 상자의 구성 탭에서 편집… 단추를 클릭합니다.

  7. 디렉터리 문자열을 적절하게 편집합니다. 확인을 클릭하고 적용을 클릭한 다음 다시 확인을 클릭하여 변경 내용을 저장합니다.

참고 항목

개념

지원되는 SMS 구성

기타 리소스

SMS 2003 Management Pack 문제 해결
System Management Server 2003 Management Pack 개요
Microsoft System Management Server 2003 Management Pack용 참조


Microsoft System Management Server 2003 Management Pack용 참조

이 단원에서 소개하는 참조 자료는 Operations Manager 2007 및 System Management Server 2003에 대한 지침을 제공합니다.

이 섹션에서

Microsoft System Management Server 2003 Management Pack용 추가 리소스

SMS 2003 Management Pack의 사이트 및 구성 요소

SMS 2003의 컴퓨터 그룹

SMS 2003의 규칙 그룹

SMS 2003의 공급자

SMS 2003의 스크립트

Microsoft SMS 2003의 뷰

SMS 2003의 다이어그램

SMS 2003의 보고서

참고 항목

개념

Management Pack 모니터링 시나리오
SMS 2003 Management Pack 배포

기타 리소스

System Management Server 2003 Management Pack 개요
SMS 2003 Management Pack의 운영 작업 수행
SMS 2003 Management Pack 문제 해결


Microsoft System Management Server 2003 Management Pack용 추가 리소스

다음은 Microsoft System Management Server 2003 Management Pack에서 사용할 수 있는 리소스입니다.

Microsoft Operations Manager 2007

인터넷에 있는 Operations Manager 2007 핵심 제품 설명서에 액세스하고 System Center Operations Manager 2007에 대한 최신 정보를 보려면 Operations Manager 2007 제품 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

SMS 2003

SMS 2003을 배포하고 사용하는 데 필요한 모든 정보는 핵심 제품 설명서, SMS Administrator 콘솔 도움말, SMS 용어집 및 SMS Online Library에 제공되어 있습니다. SMS Online Library 및 SMS Administrator 콘솔 도움말은 SMS Administrator 콘솔에서 액세스할 수 있습니다.

SMS 2003 Online Library

SMS Online Library에서는 SMS를 배포하고 사용하는 데 필요한 모든 정보에 대한 포인터를 제공합니다. SMS 2003을 설치한 후 다음 두 가지 방법으로 SMS Online Library를 실행할 수 있습니다.

  • 시작 메뉴에서 프로그램, Systems Management Server를 차례로 클릭하고 SMS Online Library를 선택합니다.
  • SMS Administrator 콘솔 트리에서 SMS Online Library를 마우스 오른쪽 단추로 클릭하고 Run Online Library를 클릭합니다.

Online Library에는 다음 항목이 포함되어 있습니다.

  • SMS에 대한 중요 정보가 들어 있는 "SMS 2003 Release Notes"
  • 이번 버전 SMS 2003과 이전 버전과의 차이점을 설명하는 "What’s New in this Version of SMS"
  • SMS 제품 설명서 웹 페이지에 대한 링크
  • SMS 2003 Device Management Feature Pack 및 SMS 2003 Operating System Deployment Feature Pack의 다운로드 페이지에 대한 링크

SMS 관련 웹 리소스

  • 관련 제품에 대한 기술 보고서 및 정보를 찾으려면 Microsoft Systems Management Server 2003 제품 웹 사이트를 참조하십시오. SMS 웹 사이트에서는 Microsoft Windows® XP, Microsoft Office XP 등의 다른 Microsoft 제품과 SMS를 함께 사용하는 방법에 대한 구체적인 정보도 제공합니다.
  • 찾아서 다운로드할 수 있는 버전의 SMS 2003 핵심 제품 설명서에 대한 링크는 Systems Management Server 2003 제품 설명서 웹 페이지를 참조하십시오.
  • Microsoft에서는 질문을 게시하고 동료나 SMS 제품 팀의 구성원으로부터 무료 지원을 받을 수 있는 여러 종류의 무료 뉴스 그룹을 유지 관리합니다. 무료 뉴스 그룹에 대한 자세한 내용은 Systems Management Server Community 웹 페이지를 참조하십시오.
  • 기술 문서, FAQ, 웹캐스트, 뉴스 그룹 등에 대한 자세한 내용은 Support for Systems Management Server 웹 페이지를 참조하십시오.
  • Microsoft 기술 자료 문서 및 기타 기술 리소스에서 SMS 질문에 대한 빠르고 정확한 답을 검색하려면 Microsoft 도움말 및 지원 웹 사이트를 방문하십시오. 문제에 할당된 "Qxxxxxx" 번호나 "xxxxxx" 번호로 기술 자료를 쿼리하여 특정 문제에 대한 문서를 찾을 수 있습니다.

사용자 의견 제공

  • SMS 설명서 팀에 사용자 의견을 보내 주시면 사용자에게 가장 필요한 제품 정보를 제공하는 데 많은 도움이 됩니다. SMS 설명서 팀에 설명서에 대한 의견을 보내 주십시오.

참고 항목

개념

SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003 Management Pack의 사이트 및 구성 요소

SMS 2003 구성 요소에는 SMS 중앙 사이트 서버, SMS 사이트 데이터베이스 및 SMS Administrator 콘솔이 포함됩니다. 일반적으로 SMS 중앙 사이트 서버, SMS 사이트 데이터베이스 및 SMS Administrator 콘솔은 동일한 서버에 있으며 각 사이트 시스템 역할은 전용 서버에 있습니다. 중앙 사이트 서버 및 데이터베이스는 사이트 시스템 역할과 함께 단일 SMS 사이트를 구성합니다. 단일 SMS 사이트에는 중복 사이트 시스템 역할이 여러 개 포함될 수 있습니다. 예를 들어 한 사이트에 여러 개의 CAP(클라이언트 액세스 지점)가 포함될 수 있습니다. SMS 2003 사이트는 계층으로 구성될 수 있으며 하나의 SMS 사이트에 서버 검색 지점과 같은 일부 사이트 서버 역할을 포함하지 못할 수 있습니다.

SMS 2003 Management Pack은 SMS 서버 구성 요소를 모니터링하기 위한 것으로서 SMS 클라이언트 컴퓨터의 SMS 기능을 모니터링하기 위한 것이 아닙니다. 그러나 Operations Manager 2007은 SMS 클라이언트 컴퓨터에 있는 다른 응용 프로그램을 모니터링하는 데 사용할 수 있습니다.

SMS 2003 구성 요소에 대한 자세한 내용은 SMS 2003 Online Library를 참조하십시오. SMS 2003 설명서에 대한 링크는 이 가이드의 Microsoft System Management Server 2003 Management Pack용 추가 리소스 단원을 참조하십시오.

주요 서버 역할 및 구성 요소에는 다음이 포함됩니다.

  • 클라이언트 액세스 지점
  • 배포 지점
  • 관리 지점
  • 서버 검색 지점
  • 보고 지점
  • 사이트 서버
  • 사이트 데이터베이스
  • 발신자
  • 고급 클라이언트
  • 레거시 클라이언트
  • SMS 공급자
  • SMS Administrator 콘솔

클라이언트 액세스 지점

CAP 역할은 레거시 클라이언트와 SMS 사이트 서버 간의 연락 지점입니다. CAP는 모든 레거시 클라이언트 데이터를 사이트 서버에 전달합니다. 레거시 클라이언트 컴퓨터는 CAP를 통해 SMS 사이트 서버의 관리 정보를 얻습니다. CAP는 하나의 SMS 사이트만 처리하며 기본적으로 사이트 서버에 설치됩니다. CAP는 다음과 같은 역할도 합니다.

  • 클라이언트 설치 도중과 클라이언트 설치 후 변경 내용이 있을 때 레거시 클라이언트에 특정 구성 지침 및 파일을 제공합니다.
  • 레거시 클라이언트 컴퓨터에서 보급을 검사하는 위치로 사용됩니다.
  • 레거시 클라이언트에서 데이터를 받아 SMS 사이트 서버에 전달합니다. 예를 들어 클라이언트가 하드웨어 또는 소프트웨어 인벤토리를 완료하고 인벤토리 데이터 파일을 만든 경우 이 데이터를 CAP에 보냅니다. 클라이언트에서 생성된 상태 메시지는 CAP에 복제됩니다.

배포 지점

배포 지점에는 SMS에서 배포한 소프트웨어 프로그램을 설치할 때 SMS 클라이언트에서 사용하는 SMS 패키지 원본 파일이 저장됩니다. SMS 관리자가 프로그램을 보급할 경우 클라이언트는 레거시 클라이언트용 CAP나 고급 클라이언트용 관리 지점을 통해 보급 및 프로그램 정보를 사용할 수 있습니다.

SMS가 설정되면 사이트 서버에는 배포 지점 역할이 자동으로 할당됩니다. SMS 관리자는 배포 지점에서 BITS(Background Intelligent Transfer Service)를 사용할 수 있게 할 수 있습니다. 이렇게 하면 증분 패키지 파일을 고급 클라이언트에 다운로드할 수 있습니다.

고급 클라이언트는 BITS를 사용하여 클라이언트 네트워크 연결 용량을 자동으로 감지하고 전송 속도를 효율적으로 조정할 수 있습니다. 이러한 기능은 Microsoft Windows 2000, Microsoft Windows XP Professional 및 Microsoft Windows Server™ 2003 운영 체제를 실행하는 클라이언트에서만 지원됩니다.

관리 지점

관리 지점은 고급 클라이언트와 SMS 사이트 서버 간의 주 연락 지점입니다. Windows 네트워크 로드 균형 조정 서비스를 사용하여 여러 개의 관리 지점을 구성할 수도 있지만 SMS 사이트에는 하나의 기본 관리 지점만 있습니다. CAP와 레거시 클라이언트 간의 관계와 유사하게 관리 지점은 다음과 같은 역할을 합니다.

  • 클라이언트가 설치된 후 고급 클라이언트에 특정 클라이언트 구성 정보(고급 클라이언트 정책이라고도 함)를 제공합니다.
  • 고급 클라이언트 컴퓨터에서 보급을 검사하는 위치로 사용됩니다.
  • 고급 클라이언트의 배포 지점을 찾습니다.
  • 고급 클라이언트에서 인벤토리, 소프트웨어 미터링 및 상태 정보를 받아 이를 SMS 사이트 서버로 전달합니다.

서버 검색 지점

서버 검색 지점은 레거시 클라이언트의 CAP 및 고급 클라이언트의 관리 지점을 찾습니다. 서버 검색 지점은 대부분 클라이언트를 설치할 때 사용됩니다. 서버 검색 지점은 다음과 같은 역할을 합니다.

  • 고급 클라이언트가 자동 SMS 사이트 할당에 맞게 구성된 경우 고급 클라이언트의 관리 지점을 찾습니다.
  • 로그온 스크립트를 기반으로 클라이언트를 설치할 때와 충분한 자격 증명 없이 설치할 때 고급 클라이언트에 관리 지점의 위치를 제공합니다.
  • 레거시 클라이언트에 SMS 사이트를 할당하고 로그온 스크립트를 기반으로 클라이언트를 설치할 때 CAP를 찾습니다.

보고 지점

보고 지점은 IIS(인터넷 정보 서비스)를 실행하는 서버로서 Report Viewer와 추가 보고서의 코드를 호스팅합니다. 보고 지점은 SMS 사이트 데이터베이스 서버와만 통신합니다.

고급 클라이언트

SMS 2003에서는 고급 클라이언트를 통해 모바일 컴퓨팅을 처리할 수 있습니다. 고급 클라이언트는 소프트웨어 배포, 자산 관리 및 원격 문제 해결을 비롯한 전체 SMS 기능 집합을 지원합니다. 모바일 사용자와 데스크톱 사용자를 구별 없이 모두 관리할 수 있습니다. 고급 클라이언트에서는 BITS라는 Windows 기술을 사용하여 모든 관리 작업에 필요한 연결을 제공합니다.

레거시 클라이언트

조직에서 고급 클라이언트를 지원하기 위한 요구 사항을 충족하지 않는 컴퓨터를 관리해야 하는 경우 레거시 클라이언트를 사용할 수 있습니다. 다음과 같은 레거시 클라이언트 설치 방법을 사용하도록 설정하고, 구성하고, 제어할 수 있습니다.

  • 로그온 스크립트 기반 클라이언트 설치
  • 클라이언트 강제 설치
  • 수동 클라이언트 설치

SMS 공급자

SMS 공급자는 SMS 사이트 데이터베이스의 데이터 요청을 처리합니다. SMS 공급자 역할은 SMS 사이트 서버나 SMS 사이트 데이터베이스와 같은 컴퓨터에 설치됩니다. 사이트 서버에 SMS 공급자와 SMS 사이트 데이터베이스를 모두 설치하는 것이 좋습니다. 사이트에 설치된 SMS Administrator 콘솔에서 SMS 공급자를 통해 데이터에 액세스할 수 있습니다.

SMS Administrator 콘솔

SMS Administrator 콘솔은 SMS를 관리하는 데 사용되는 그래픽 사용자 인터페이스입니다. 이 인터페이스에는 SMS 제품 소프트웨어와 함께 제공되는 MMC(Microsoft Management Console) 스냅인이 사용됩니다. SMS Administrator 콘솔은 기본적으로 주 사이트 서버를 설치할 때 설치됩니다. 또한 다른 서버나 워크스테이션에도 설치됩니다.

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 컴퓨터 그룹

SMS 2003 Management Pack에서는 다음과 같은 컴퓨터 그룹을 제공합니다.

  • Microsoft SMS 2003 Administrator Consoles
  • Microsoft SMS 2003 Advanced Clients
  • Microsoft SMS 2003 Central Site Servers
  • Microsoft SMS 2003 Clients
  • Microsoft SMS 2003 Client Access Point Servers
  • Microsoft SMS 2003 Component Servers Based on IIS
  • Microsoft SMS 2003 Component Servers Based on SMS Executive
  • Microsoft SMS 2003 Distribution Point Servers
  • Microsoft SMS 2003 Management Point Servers
  • Microsoft SMS 2003 Primary Site Servers
  • Microsoft SMS 2003 Providers
  • Microsoft SMS 2003 Reporting Point Servers
  • Microsoft SMS 2003 Secondary Site Servers
  • Microsoft SMS 2003 Sender Servers
  • Microsoft SMS 2003 Server Locator Point Servers
  • Microsoft SMS 2003 Servers
  • Microsoft SMS 2003 Site Servers
  • Microsoft SMS 2003 Legacy Clients

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 규칙 그룹

이 단원에는 Systems Management Server(SMS) 2003 Management Pack에서 중요한 이벤트 및 경고를 생성하는 규칙 그룹과 이벤트 규칙의 목록이 있습니다. 규칙 그룹의 모든 규칙을 검토하려면 Operations Manager 2007 작업 콘솔에서 제작 창을 확인하십시오.

SMS 클라이언트 - 고급

SMS 클라이언트 - 고급 규칙 그룹에는 SMS 고급 클라이언트와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS 에이전트 호스트
  • SMS 2003 종속 서비스 실행 중: BITS(Background Intelligent Transfer Service)
  • SMS 2003 종속 서비스 실행 중: Windows Management Instrumentation

SMS 클라이언트 액세스 지점

SMS 클라이언트 액세스 지점 규칙 그룹에는 SMS 클라이언트 액세스 지점과 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS_EXECUTIVE

SMS 관리 지점

SMS 관리 지점 규칙 그룹에는 SMS 관리 지점과 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS 에이전트 호스트
  • SMS 2003 서비스 실행 중: SMS_EXECUTIVE
  • SMS 2003 종속 서비스 실행 중: World Wide Web Publishing 서비스
  • SMS 2003 종속 서비스 실행 중: IIS Admin Service
  • SMS 2003 관리 지점 상태: 상태
  • SMS 2003 성능 임계값: 3시간 동안의 MP DDR 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 MP HINV 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 MP SINV 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 MP FileCollection 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 MP Relay Mgr 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 MP 상태 백로그 > 10,000
  • SMS 2003 성능 임계값: 프로세스 - 3시간 동안의 % 프로세서 시간(ccmexec) > 95

SMS 공급자

SMS 공급자 규칙 그룹에는 SMS 2003의 SMS 공급자 구성 요소와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 종속 서비스 실행 중: Windows Management Instrumentation

SMS 보고 지점

SMS 보고 지점 규칙 그룹에는 SMS 보고 지점과 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS_REPORTING_POINT
  • SMS 2003 종속 서비스 실행 중: World Wide Web Publishing 서비스
  • SMS 2003 종속 서비스 실행 중: IIS Admin Service

SMS 발신자 서버

SMS 발신자 서버 규칙 그룹에는 SMS 발신자 서버와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS_EXECUTIVE

SMS 서버 검색 지점

SMS 서버 검색 지점 규칙 그룹에는 SMS 서버 검색 지점과 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 종속 서비스 실행 중: World Wide Web Publishing 서비스
  • SMS 2003 종속 서비스 실행 중: IIS Admin Service
  • SMS 2003 서비스 실행 중: SMS_SERVER_LOCATOR_POINT

SMS 서버 - 일반

SMS 서버 - 일반 규칙 그룹에는 모든 SMS 서버와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 성능 임계값: 페이징 파일 - 3시간 동안의 %사용 > 98
  • SMS 2003 성능 임계값: 프로세서 - 3시간 동안의 % 프로세서 시간(_Total) > 95

SMS Executive 기반 SMS 서버

SMS Executive 기반 SMS 서버 규칙 그룹에는 SMS Executive 서비스를 실행하는 모든 사이트 서버에서 생성되는 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 성능 임계값: 프로세스 - 3시간 동안의 % 프로세서 시간(smsexec) > 95

SMS 사이트 데이터베이스 서버

SMS 사이트 데이터베이스 서버 규칙 그룹에는 SMS 사이트 데이터베이스 서버와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS_SQL_MONITOR
  • SMS 2003 종속 서비스 실행 중: MSSQLSERVER
  • SMS 2003 성능 임계값: 2시간 동안의 SMS SQL 연결 수 > 500

SMS 사이트 서버 - 일반

SMS 사이트 서버 - 일반 규칙 그룹에는 모든 SMS 사이트 서버와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 서비스 실행 중: SMS_SITE_COMPONENT_MANAGER
  • SMS 2003 서비스 실행 중: SMS_EXECUTIVE
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 스케줄러 작업 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 스케줄러 보내기 요청 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 SWM 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 SINV 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 HINV 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 DDR 백로그 > 10,000

SMS 사이트 데이터베이스 서버 - 기본

SMS 사이트 서버 - 기본 규칙 그룹에는 모든 SMS 주 사이트 서버와 관련된 오류에 대한 다음 규칙이 포함되어 있습니다.

  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 SINV 백로그 > 10,000
  • SMS 2003 성능 임계값: 3시간 동안의 사이트 서버 HINV 백로그 > 10,000

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 공급자

SMS 2003 Management Pack에서 사용하는 데이터 공급자 유형은 다음과 같습니다.

  • 응용 프로그램 로그
  • 시간 제한 이벤트
  • Windows NT 성능 카운터

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 스크립트

SMS 2003 Management Pack에는 에이전트에서 자동으로 실행되는 Operations Manager 2007 스크립트와 관리자가 직접 실행해야 하는 스크립트가 포함되어 있습니다. 이 단원에서는 이러한 스크립트에 대한 추가 정보를 설명합니다.

다음 스크립트는 Operations Manager 2007 에이전트에 의해 자동으로 실행됩니다.

  • SMS 2003 SMS 상태 메시지 모니터
  • SMS 2003 사이트 시스템 요약 작성기 모니터
  • SMS 2003 서비스 검색 – 클라이언트
  • SMS 2003 서비스 검색 – 서버
  • SMS 2003 사이트 백업 이벤트 제거
  • SMS 2003 관리 지점 상태 모니터
  • SMS 2003: 관리 지점 가용성 모니터
  • SMS 2003 사이트 계층 구조 검색
  • SMS 2003 SMS 수신함 모니터
  • SMS 2003 SMS Executive 크래시 덤프 모니터

SMS 2003 SMS 상태 메시지 모니터

SMS에서 발생하는 많은 문제는 SMS 상태 시스템을 통해 내부적으로 감지되고 보고됩니다. 상태 메시지는 SMS Administrator의 관심 조건에 따라 SMS 구성 요소에 의해 발생합니다.

상태 메시지는 SMS 사이트의 데이터베이스로 전달되고 부모 사이트의 데이터베이스에서 사이트 계층 구조의 상위로도 전달됩니다. 지정한 사이트 데이터베이스의 SMS 상태 메시지 표를 쿼리하기만 하면 SMS 상태 시스템을 사이트별로 모니터링할 수 있습니다.

SMS Administrator에게 가장 중요한 이벤트를 반영하는 상태 메시지 집합을 모니터링하도록 선택한 경우, 이러한 메시지 중 하나가 데이터베이스에서 발견되면 경고가 생성됩니다.

이 스크립트는 다음 작업을 수행합니다.

  • 스크립트가 에이전트 없는 관리되는 모드에서 실행 중인지 확인합니다. 에이전트 없는 관리되는 모드에서 실행 중인 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다.
  • 전역 변수를 초기화합니다.
  • SMS 2003 Monitor SMS Status Messages.VarSet 파일에서 모니터링되는 각 SMS 사이트 데이터베이스에 대해 마지막으로 처리된 상태 메시지의 RecordID를 열고 읽습니다.
  • 로컬 컴퓨터의 각 SMS 사이트 데이터베이스에서 발견된 상태 메시지를 처리합니다.
  • 모니터링되는 각 SMS 사이트 데이터베이스에 대해 마지막으로 처리된 상태 메시지의 RecordID를 SMS 2003 Monitor SMS Status Messages.VarSet 파일에 쓰고 해당 파일을 닫습니다.

SMS 2003 SMS 상태 메시지 모니터 스크립트는 이벤트 ID를 보고되는 해당 SMS 상태 메시지의 ID로 설정하여 이벤트를 발생시킵니다. 표 S.1에서는 발생하는 이벤트의 형식을 설명합니다.

표 S.1 SMS 2003 SMS 상태 메시지 모니터 스크립트에서 발생하는 이벤트 형식

매개 변수 | 설명
EventType | SMS 상태 메시지의 심각도에 따라 성공, 오류, 경고 또는 정보
EventNumber | SMS 상태 메시지 ID
Category | SMS 사이트 코드
LoggingDomain | 컴퓨터의 리소스 도메인
LoggingComputer | 컴퓨터의 NetBIOS 이름
Parameter1 | 컴퓨터의 NetBIOS 이름
Parameter2 | SMS 모듈 이름(예: SMS 서버)
Parameter3 | SMS 구성 요소 이름
Parameter4 | SMS 메시지 ID
Parameter5 | Win32 오류 코드
Parameter6 | 부모 또는 최상위 사이트 코드
Parameter7 | SMS 상태 메시지 표에 있는 상태 메시지의 RecordID
Description | "A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database.”

SMS 2003 SMS 상태 메시지 모니터 스크립트에서는 다음과 같이 상태 메시지 ID 번호 1102를 통해 스크립트 오류도 보고합니다.

EventType = Warning

EventNumber = 1102

Description = The script SMS 2003 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error. The error message will contain the text “Failed to <ErrorDescription>.”

모든 SMS 2003 상태 메시지 모니터링 이벤트 규칙은 "SMS 2003 상태:"로 시작되며 SMS Site Database Servers 규칙 그룹에 포함되어 있습니다.

  • SMS 2003 상태: 메시지 모니터링

SMS 2003 상태: Message Monitoring은 SMS 2003에서 30분마다 예약, 00:02에 동기화 시간 제한 이벤트 공급자를 사용하여 스크립트를 실행합니다. 요약 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • SMS 2003 상태: 스크립트 오류

SMS 2003 상태: 스크립트 오류는 발생할 수 있는 스크립트 오류 이벤트를 모니터링하고 이를 알립니다. 여기에는 모든 스크립트 오류를 보고하는 스크립트 오류 이벤트(번호 1102) 하나만 있습니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • SMS 2003 상태: <status message name>

SMS 2003 상태: <status message name>은 특정 상태 메시지 이벤트를 모니터링하고 이를 알립니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

모든 경고에는 다음 형식의 이벤트 설명이 있습니다. 여기에서 $Description$은 이벤트 설명입니다.

$Logging Computer$ - "Rule Name". $Description$

SMS 2003 Monitor SMS Status Messages.VarSet 파일은 마지막으로 처리된 상태 메시지의 RecordID를 사이트 데이터베이스별로 저장하는 데 사용됩니다. VarSet 파일은 Windows\Temp 디렉터리에 있으며 탭으로 구분된 다음 형식의 파일입니다.

코드 복사
LastRecordID_DBNameRecordID#

예를 들어 RecordID가 477860인 LastRecordID_SMS_FLA는 SMS_FLA라는 사이트 데이터베이스에서 마지막으로 처리된 RecordID가 477860임을 나타냅니다.

Management Pack을 이전 버전에서 업그레이드하면 SMS 2003 Monitor SMS Status Messages.VarSet 파일에 다음과 같이 표시됩니다.

코드 복사
LastRecordID476743
LastRecordID_SMS_FLA477860

데이터베이스 이름이 들어 있지 않은 첫 번째 줄은 원래 버전의 상태 메시지 모니터링이 여러 데이터베이스의 모니터링을 지원하지 않음을 나타냅니다. 데이터베이스 이름 SMS_FLA가 들어 있는 두 번째 줄은 현재 버전의 상태 메시지 모니터링이 여러 데이터베이스의 모니터링을 지원함을 나타냅니다.

사이트 데이터베이스가 여러 개인 경우에는 해당하는 데이터베이스를 확인하기가 어려우므로 첫 번째 줄의 데이터를 이용하는 작업은 수행되지 않습니다. 첫 번째 줄의 데이터는 업그레이드 후 새 변경 내용을 평가하고 상태 메시지 모니터링이 올바른 RecordID로 시작되도록 하는 데 중요한 역할을 할 수 있으므로 VarSet 파일에서 제거되지 않습니다.

SMS 2003 사이트 시스템 요약 작성기 모니터

사이트 시스템 요약 작성기

Site System Status Summarizer는 정의된 모든 SMS 사이트 시스템의 상태를 유지 관리하는 SMS Executive 서비스의 구성 요소 스레드로서, 기본적으로 현재 상태에 대해 매시간마다 한 번씩 폴링합니다. 이 폴링 간격은 SMS 사이트 제어 파일에 정의되어 있습니다. 폴링 간격은 변경하지 않는 것이 좋습니다. 상태는 SMS 사이트 데이터베이스의 테이블에서 유지 관리됩니다.

사이트 시스템 DownSince 상태

Site System Status Summarizer에서는 각 폴링 주기 도중 사이트 시스템에 연결할 수 없으면 사이트 시스템이 종료된 것으로 간주합니다. 사이트 시스템에 연결할 수 없는 것은 다음 요인 중 하나 때문일 수 있습니다.

  • 사이트 시스템이 켜져 있지 않거나, 네트워크에 연결되어 있지 않거나, 제대로 동작하지 않는 경우
  • 사용할 수 있는 연결이 없어서 SMS Site System Status Summarizer가 연결되어 있지 않은 경우
  • SMS Site System Status Summarizer에 사이트 시스템에 연결할 수 있는 충분한 액세스 권한이 없는 경우
  • 네트워크 문제로 인해 SMS Site System Status Summarizer에서 사이트 시스템에 연결할 수 없는 경우
  • 사이트 시스템의 서비스가 영구적으로 정지된 경우

Site System Status Summarizer 기반 가용성

Site System Status Summarizer 상태는 SMS 2003 Server Availability 스크립트 및 SMS 2003 서버 가용성 보고서에서 가용성을 보고하는 데 사용됩니다. SMS 서버 가용성을 측정할 때는 DownSince 레지스트리 값을 이용하여 서버의 사용 가능 여부를 확인합니다.

Site System Status Summarizer 기반 가용성의 제한 사항

이 단원에서는 SMS 2003 Server Availability 스크립트 및 SMS 2003 서버 가용성 보고서에서 사이트 시스템 요약 작성기 상태를 사용하여 가용성을 보고할 때의 제한 사항을 설명합니다. SMS 서버 가용성을 측정할 때는 "DownSince" 상태를 이용하여 서버의 사용 가능 여부를 확인합니다.

Site System Status Summarizer 기반 가용성 모니터링에는 다음과 같은 제한 사항이 있습니다.

  • 사이트 시스템 요약 작성기 폴링 간격은 1시간입니다. 이 간격은 Site System Status Summarizer에서 모든 사이트 시스템을 폴링할 수 있는 충분한 시간입니다. 성능상의 이유로 이 간격은 변경할 수 없습니다. Site System Status Summarizer의 시간 제한 간격은 사이트 제어 파일의 Wakeup Interval 속성이 아니라 Startup Schedule 속성에 의해 제어됩니다. 따라서 Wakeup Interval 속성을 기본값 60에서 다른 값으로 변경해도 아무런 효과가 없습니다. 또한 Startup Schedule을 변경해도 아무런 효과가 없습니다. 기본적으로 이 속성은 15분으로 설정되어 있으며 Site System Status Summarizer에서는 Startup Schedule의 설정에 관계없이 매시간마다 한 번씩 사이트 시스템을 폴링합니다.
  • 가용성 확인 방법에서는 2시간 동안 SMS 2003 사이트 시스템 요약 작성기: 사이트 시스템이 중지되었을 수 있음 이벤트가 두 번 연속으로 발생하는 경우에만 해당 사이트를 사용할 수 없는 것으로 간주합니다. 이는 네트워크가 임시로 정전될 경우를 고려한 것입니다. 즉 사이트를 짧은 시간 동안 사용할 수 없더라도 서비스가 두 시간 동안 정지된 것으로 평가됩니다.
  • SMS는 Site System Status Summarizer에서 모니터링하지 않는 여러 가지 방식으로 사용 불가능 상태가 될 수 있습니다. 예를 들어 Site System Status Summarizer에서는 SMS 서비스가 실행되고 있지 않거나 SMS 사이트 데이터베이스를 사용할 수 없는 경우에는 SQL Server 서비스가 중지되었을 때와 같이 SMS를 사용할 수 없는 것으로 간주하지 않습니다.
  • 여러 SMS 서버 역할을 호스팅하는 컴퓨터의 경우 가용성 데이터가 영향을 받습니다. 가동 중지 시간은 가동 중지된 사이트 시스템에 대해 생성된 경고를 기준으로 계산됩니다. 경고가 한 번 있을 때마다 가동 중지 시간이 2시간씩 늘어납니다. Site System Status Summarizer는 컴퓨터에서 호스팅되는 각 사이트 개체 및 사이트 시스템 역할의 현재 "DownSince" 상태를 데이터베이스의 Site System Status Summarizer 테이블에 기록합니다.

Site System Status Summarizer 모니터링 스크립트는 Site System Status Summarizer 테이블에서 각 사이트 시스템 역할을 검사하고, 사이트 시스템이 중지된 것으로 표시되어 있으면 이벤트를 발생시킵니다. 그런 다음 이 이벤트에 따라 경고가 생성됩니다. 여러 개의 역할에서 여러 개의 경고가 생성되면 가동 중지 시간이 늘어납니다. 이는 지정한 간격에 따라 음의 가용률로 반영될 수 있습니다.

SMS 배포 지점을 제외한 각 SMS 서버 역할은 기본적으로 두 개의 SMS 서버 역할을 구성합니다. 하나는 특정 역할용이고 다른 하나는 SMS 구성 요소 서버용입니다. 예를 들어 서버 검색 지점과 보고 지점을 모두 호스팅하는 사이트 시스템의 경우 서버가 2시간 이상, 즉 Site System Status Summarizer 폴링 주기를 두 번 이상 거치는 동안 오프라인 상태였으면 Site System Status Summarizer는 이 두 역할과 해당 SMS 구성 요소 서버 역할을 중지된 것으로 표시합니다.

그러나 경고는 2시간 동안 각 폴링 간격마다 세 개씩(각 서버 역할에 대한 경고 두 개와 두 개의 서버 역할을 호스팅하는 실제 구성 요소 서버에 대한 경고 하나)만 발생합니다. 따라서 2시간 동안 6시간을 사용할 수 없는 것으로 표시되므로 음의 가용량이 계산되는 결과가 생깁니다.

  • Site System Status Summarizer 폴링 간격(1시간)이 시작된 지 10분 후에 SMS 2003 사이트 시스템 요약 작성기 모니터 스크립트가 실행되도록 기본적으로 매시간 10분의 차이가 나는 60분 주기가 설정되어 있습니다. Site System Status Summarizer가 해당 주기를 완료하는 데 10분 이상 소요될 경우에는 시간 제한 이벤트 공급자 오프셋을 적절하게 늘려야 합니다. 그렇지 않으면 최근 사이트 시스템 상태 메시지를 잃게 됩니다.

SMS 2003: 관리 지점 가용성 모니터

SMS 2003 관리 지점 가용성 모니터 스크립트는 관리 지점 가용성 보고서를 지원합니다. 가용성은 관리 지점의 상태를 기반으로 하며 레지스트리에 있는 다음 상태 값을 이용합니다.

DWORD 값 HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

이 스크립트는 Operations Manager 2007 이벤트를 통해 구성 가능한 일정 및 보고 간격을 기준으로 상태가 비정상적인 기간(레지스트리 값이 0이 아니라 1임)을 읽고 보고합니다.

이러한 가용성 데이터 이벤트는 OperationsManager 데이터베이스와 OperationsManagerDW 데이터베이스에 기록됩니다. 그런 다음 지정된 간격 동안 관리 지점이 중지된 총 시간과 가용률을 표시하는 Operations Manager 2007 보고서가 실행될 수 있습니다.

MPHealthState 레지스트리 값은 MP Control Manager가 유지 관리하며 6시간마다 업데이트됩니다.

이 스크립트는 다음 작업을 수행합니다.

  • 스크립트가 에이전트 없는 관리되는 모드에서 실행 중인지 확인합니다. 에이전트 없는 관리되는 모드에서 실행 중인 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다. 이 스크립트는 로컬 VarSet 파일을 사용하여 변수를 저장하므로 Operations Manager 2007 에이전트가 설치되어 있어야 합니다.
  • 전역 변수를 초기화합니다.
  • 입력 매개 변수 ScheduledInterval 및 ReportingInterval(분)을 가져옵니다.
  • 입력 매개 변수가 0 또는 음수이거나 비어 있지 않은지 확인합니다. 그럴 경우 유효하지 않은 값이 지정되었음을 나타내는 스크립트 오류 이벤트가 발생합니다. 또한 이 스크립트는 ReportingInterval 값이 ScheduledInterval 값보다 작지 않은지 확인합니다. 그럴 경우 ReportingInterval은 ScheduledInterval보다 작을 수 없음을 나타내는 스크립트 오류 이벤트가 발생합니다. 두 값은 모두 Lng 형식을 구현하며 최대값이 2147483647(2G -1)입니다.
  • SMS 2003 Monitor Management Point Availability.VarSet 파일을 열고 해당 내용을 로컬 컬렉션에 복사합니다. 이 파일이 없더라도 스크립트 오류 이벤트는 발생하지 않습니다. 파일이 있지만 열 수 없으면 스크립트 오류 이벤트가 발생합니다.
  • 관리 지점의 가용성을 확인합니다.
    • 현재 SMS 버전이 2.50.3067.0000보다 낮으면 MPHealthState 레지스트리 값이 없으므로 오류 없이 스크립트가 종료됩니다. AgentResponses-Configuration Group Name.log라는 에이전트 응답 로그 파일에는 "Monitoring Management Point health is not supported on this SMS build"라는 설명이 포함됩니다. HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager 키 아래의 EnableActiveDebugging DWORD 값을 1로 설정하면 로깅을 사용하도록 설정됩니다.
    • 레지스트리 DWORD 값 HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState에서 현재 관리 지점 상태를 가져옵니다. 이 값을 가져올 수 없으면 MP Control Manager가 아직 해당 값을 만들지 않은 것이므로 오류 없이 스크립트가 종료됩니다.
    • VarSet 컬렉션에서 시작 날짜 및 시간을 가져옵니다. 스크립트가 처음 실행되어 새 보고 기간이 시작된 경우에는 항목이 없습니다. 스크립트는 오류 없이 종료되기 전에 VarSet 컬렉션의 기간 및 시작 날짜를 초기화하고 기간을 0으로, 시작 날짜를 현재 날짜 및 시간으로 설정합니다.
    • 현재 보고 간격의 경우 MPHealthState 레지스트리 값이 1이면 스크립트는 VarSet 컬렉션에서 지정된 일정 간격을 기준으로 사용할 수 없는 기간을 늘립니다.
    • 보고 간격이 경과되었고 관리 지점이 사용할 수 없는 상태이면 가용성 데이터 이벤트를 만들어 이를 보고합니다. 스크립트는 VarSet 컬렉션에서 기간을 0으로 다시 설정하고 시작 날짜를 다음 보고 기간의 현재 로컬 시간으로 다시 설정합니다.
    • 관리 지점의 가용성을 확인하는 동안 오류가 발생하면 스크립트 오류가 발생합니다.

Event Number = 1102

Event Type = Warning

Message = "The script ‘SMS 2003 Monitor Management Availability' running under processing rule <ProcessingRuleName> encountered a runtime error." CrLf "Failed to check Management Point availability.” <ErrorString>

  • VarSet 컬렉션의 내용을 로컬 SMS 2003 Monitor Management Point Availability.VarSet 파일에 쓰고 이 파일을 닫습니다. 이 파일이 없으면 자동으로 만들어집니다. VarSet 변수가 설정되지 않은 경우에는 파일에 해당 항목이 나타나지 않습니다. 파일을 쓰는 동안 오류가 발생하면 스크립트는 스크립트 오류를 발생시킵니다.

SMS 2003: SMS 수신함 모니터

SMS는 수신함의 파일을 읽고 수신함의 파일에 쓰는 방법으로 대부분의 서버 쪽 주요 작업을 수행합니다. SMS 수신함이 비정상적으로 가득 차면 이는 SMS 처리 속도가 저하되었음을 나타냅니다. 여기에는 잘못된 파일, 중지된 프로세스, 디스크 공간 부족, 비정상적인 소프트웨어 배포 작업 등의 다양한 원인이 있을 수 있습니다. 이러한 문제는 매우 드물지만 사이트 수가 상당히 많은 고객에게는 심각한 문제입니다.

SMS 수신함에 대한 여러 성능 카운터는 디스크에서 처리되기를 대기하고 있는 실제 항목 수가 아니라 서비스 구성 요소에서 대기열에 넣은 항목 수를 측정합니다. SMS 서비스 구성 요소는 현재 대기열의 항목을 모두 처리한 후에 성능 카운터를 업데이트합니다. 이로 인해 성능 카운터가 매우 드물게 업데이트되고 중요한 백로그를 제때에 감지하지 못할 수 있습니다. 새로운 SMS 2003: SMS 수신함 모니터 스크립트는 중요한 SMS 서버 수신함의 파일 수를 계산하여 직접 모니터링을 추가하고 특정 수신함의 파일 수가 사용자 구성 가능한 임계값을 초과할 때 Operations Manager 2007을 통해 관리자에게 알립니다.

모든 규칙은 이러한 규칙의 대상을 중앙 사이트, 주 사이트 및 보조 사이트로 지정하는 SMS Site Servers – Common 처리 규칙 그룹에 있습니다. 스크립트에 전달된 임계값은 재정의 방식으로 구성할 수 있습니다.

성능상의 고려 사항으로 인해 이러한 규칙은 관리 지점이나 다른 SMS 사이트 시스템 역할을 대상으로 지정하지 않습니다.

일정 및 선택적 구성

수신함 모니터링의 성능 영향을 최소화하기 위해 관련 규칙이 하루에 한 번씩 실행하도록 동기화됩니다. 규칙은 오전 01:00부터 시작하여 15분 간격으로 실행되므로 한 번에 하나의 규칙만 실행됩니다. 예를 들어 첫 번째 규칙은 오전 01:00에 첫 번째 수신함에 있는 파일 수를 계산하고 두 번째 규칙은 오전 01:15에 두 번째 수신함에 있는 파일 수를 계산합니다. 이런 식으로 모든 수신함의 파일 수가 계산됩니다.

Operations Manager 2007에서 규칙 스크립트의 실행 일정을 지정할 때 수행하는 일반적인 단계에 따라 이 일정을 수정할 수 있습니다. 이 기능을 활성화하는 데 필요한 초기 구성은 없습니다. 다음은 수행 가능한 선택적 구성 변경 작업입니다.

  • 각 수신함의 기본 임계값을 변경합니다.
  • 개별 수신함 규칙의 일정을 변경합니다.

이러한 선택적 구성 변경은 Management Pack에서 임계값 이벤트 규칙을 구성하는 일반적인 단계에 따라 수행할 수 있습니다.

임계값 경고 및 값

모니터링 규칙이 처리될 때마다 특정 수신함 규칙에 대해 구성된 임계값에 도달하면 하나의 경고가 생성됩니다. 스크립트 오류 경고는 스크립트가 각 수신함의 파일 수를 모니터링하려고 시도하는 중 유효하지 않은 임계값이나 오류가 발생할 때마다 생성됩니다.

성능 임계값을 편집하려면

  1. Operations Manager 2007 관리자 콘솔에서 제작을 클릭합니다.

  2. 제작 창에서 제작 / 관리 팩 개체 / 모니터를 찾습니다.

  3. 모니터 창에서 범위를 SMS 서버로 변경합니다.

  4. SMS 서버 / Entity Health / MOM 2005 Computer Role Health를 찾은 다음 편집할 서버 역할을 확장합니다.

    • DB - 데이터베이스 서버
    • MP - 관리 지점 서버
    • SS - 사이트 서버

  5. 편집할 성능 임계값 모니터링 규칙을 두 번 클릭합니다. Performance Threshold Properties 대화 상자가 열립니다.

  6. 구성 탭을 선택합니다.

  7. 편집…을 클릭합니다. XML 구성 대화 상자가 열립니다.

  8. XML 텍스트에서 수정할 임계값을 편집합니다.

    • <CriticalErrorExpression>에 중첩된 <ValueExpression>을 지정하여 중요한 오류 임계값을 변경합니다.
    • <WarningExpression>에 중첩된 <ValueExpression>을 지정하여 경고 임계값을 변경합니다.

  9. 확인을 클릭합니다. 다시 확인을 클릭합니다. 수정된 임계값이 서버에 배포됩니다.

각 수신함 모니터링 규칙의 기본 임계값은 10,000으로 설정되어 있습니다. SMS 2003: SMS 수신함 모니터 스크립트의 FileCountThreshold 매개 변수에 대한 임계값은 사용자의 특정 환경에 맞게 설정해야 합니다. 유효한 임계값은 1에서 2147483647(0x7FFFFFFF)까지입니다. 유효하지 않은 임계값은 0이거나 2147483647보다 큰 숫자입니다. 이러한 값을 사용하면 32비트 범위에 음수가 생성됩니다.

수신함 폴더 및 Systems Management Server에서 수신함 폴더가 사용되는 방식에 대한 설명은 Microsoft 도움말 및 지원에서 관련 항목을 참조하십시오.

SMS 2003 SMS Executive 크래시 덤프 모니터 스크립트

이 스크립트는 SMS 관리자 콘솔의 Scripts 폴더에 SMS 2003 SMS Executive 크래시 덤프 모니터라는 이름으로 있습니다. 이 스크립트는 다음 작업을 수행합니다.

  • 대상 컴퓨터가 에이전트 없는 모드에서 실행되고 있는지 확인합니다. 에이전트 없는 모드에서 실행 중인 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다. 이 스크립트는 로컬 VarSet 파일을 사용하여 변수를 저장하므로 모든 대상 컴퓨터에 Operations Manager 2007 에이전트가 설치되어 있어야 합니다.
  • 로컬 SMS 2003 Monitor SMS Executive Crash Dumps.VarSet 파일을 열고 해당 내용을 컬렉션으로 읽어 들입니다. 이 파일이 없더라도 스크립트 오류 이벤트는 발생하지 않습니다. 파일이 있지만 열 수 없으면 스크립트 오류 이벤트가 발생하고 다음과 같은 메시지가 나타납니다.

Failed to load script variables.

  • 마지막으로 확인한 이후에 새 크래시 덤프가 발생했는지 여부를 확인합니다. 새 크래시 덤프가 발생한 경우 스크립트는 이벤트를 발생시켜 새 크래시 덤프를 보고합니다. 스크립트 오류 이벤트를 발생시키기 위해 스크립트는 다음을 수행합니다.
    • 레지스트리의 SMS Identification 키 아래에서 SMS 설치 디렉터리(레지스트리 값 "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory")를 확인합니다. 경로를 확인할 수 없으면 스크립트는 다음 텍스트를 표시하는 스크립트 오류 이벤트 메시지를 발생시킨 후 종료됩니다.

Failed to read registry value.

  • 검색한 SMS 설치 디렉터리에 "\Logs\CrashDumps"를 추가하여 CrashDumps 디렉터리의 전체 경로를 구성합니다.
  • CrashDumps 디렉터리가 있는지 여부를 확인합니다. 해당 디렉터리가 없으면 스크립트는 해당 폴더가 있는지를 확인할 수 없다고 기록한 후에 추가 작업 없이 종료됩니다. 에이전트 응답 로그 파일인 AgentResponses-Configuration Group Name.log에는 다음과 같은 설명이 포함됩니다.

Failed to verify existence of crash dump directory: <CrashDumpsPath>.

HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager 키 아래의 EnableActiveDebugging DWORD 값을 1로 설정하면 로깅을 사용하도록 설정됩니다.

  • VarSet 컬렉션에서 마지막 크래시 덤프 폴더를 만든 날짜를 확인합니다.
  • 새 크래시 덤프가 만들어졌는지 확인하고 최근 크래시 덤프에 대해서만 작업을 수행합니다. 최근 크래시 덤프인지 확인하기 위해 사용 가능한 경우 마지막 크래시 덤프의 저장 폴더가 생성된 날짜가 사용됩니다. 날짜 및 시간을 비교할 때는 폴더 생성 날짜 및 시간이 초 단위로 비교됩니다.
  • 새 크래시 덤프가 발생한 경우나 스크립트가 처음으로 실행된 경우 스크립트는 새 크래시 덤프 폴더 및 경로를 지정하여 이벤트 1710을 생성하고 로그에 기록합니다. 스크립트는 VarSet 컬렉션에 크래시 덤프의 폴더 생성 날짜를 저장합니다. 크래시 덤프가 발생하지 않았으면 이를 기록합니다.
  • VarSet 컬렉션의 내용을 로컬 SMS 2003 Monitor SMS Executive Crash Dumps.VarSet 파일에 쓰고 이 파일을 닫습니다. 이 파일이 없으면 자동으로 만들어집니다. VarSet 변수가 설정되지 않은 경우에는 파일에 해당 항목이 나타나지 않습니다. 파일을 쓸 때 오류가 발생하면 "Failed to save script variables."라는 스크립트 오류 이벤트 메시지가 발생합니다.

SMS 2003 SMS Executive 크래시 덤프 모니터링 이벤트

SMS 2003 SMS Executive 크래시 덤프 모니터 스크립트는 아래와 같이 이벤트 1710을 통해 크래시가 발생했음을 보고합니다.

EventType = Error

EventNumber = 1710

Category = SMS Site Code

Description = SMS Executive in site “XXX” has crashed. 자세한 내용은 <Drive>\SMS\Logs\CrashDumps\NewFolder의 크래시 덤프 정보를 참조하십시오.

SMS 2003 SMS Executive 크래시 덤프 모니터링 스크립트 오류 이벤트

“SMS 2003 SMS Executive 크래시 덤프 모니터” 스크립트는 이벤트 1102를 통해 런타임 스크립트 오류를 보고합니다.

EventType = Warning

EventNumber = 1102

Description = The script “SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps: Monitoring SMS Executive encountered a runtime error. CrLf “Failed to <Message>." ErrorString

SMS 2003 Server Availability 스크립트

SMS는 데스크톱 구성 관리에 중요한 엔터프라이즈 응용 프로그램입니다. 고객은 해당 서비스 가용성을 추적해야 합니다. Management Pack에서는 SMS Site System Status Summarizer에서 시스템 중지 시 발생하는 경고를 기반으로 SMS 사이트 시스템의 가용성을 계산하기 위한 Microsoft SQL Server™ 샘플 스크립트를 제공합니다. 지정한 기간(일 수) 동안의 가용성을 확인할 수 있습니다. 이 메트릭을 사용하여 수립된 SLA(서비스 수준 계약)를 보장할 수 있습니다.

SMS 2003 Server Availability 스크립트의 제한 사항

SMS 2003 Server Availability 스크립트에는 다음과 같은 제한 사항이 있습니다.

표시되는 데이터는 Operations Manager 2007 데이터베이스 그루밍 간격으로 제한됩니다. 기본적으로 스크립트는 최근 7일 및 최근 30일의 데이터를 반환합니다. 그러나 OperationsManager 데이터베이스의 그루밍 간격은 4일이므로 7일 및 30일 간격으로 스크립트를 실행하면 동일한 결과가 반환됩니다. 더 오랜 기간을 반영하는 보고서가 필요한 경우에는 그루밍 간격을 늘리거나 작업 데이터의 장기 저장소인 OperationsManagerDW 데이터베이스에 대해 실행되는 SMS 2003 서버 가용성 보고서를 사용해야 합니다. 더 짧은 기간을 반영하는 보고서가 필요한 경우에는 스크립트의 7일 및 30일 간격을 변경해야 합니다.

스크립트 알고리즘

사이트 시스템 요약 작성기에서는 한 시간에 한 번씩 각 사이트 시스템에 연결합니다. 사이트 시스템에 연결할 수 없으면 Site System Status Summarizer 테이블에 해당 컴퓨터는 중지된 것으로 표시됩니다. 이 경우 잘못 생성되는 보고서의 수를 줄이기 위해 Management Pack에서는 이벤트를 통합하고 2시간에 두 개의 이벤트가 발생한 경우에만 경고를 발생시킵니다. 저장 프로시저를 실행하면 저장 프로시저는 지정된 일 수 동안 발생한 “사이트 시스템이 중지되었을 수 있음” 경고의 수를 계산하고, 총 사용 가능 시간에서 가동 중지 시간을 뺀 다음, 해당 기간의 가용률을 반환합니다. 지정된 간격 동안 컴퓨터에서 “사이트 시스템이 중지되었을 수 있음” 경고를 기록하지 않은 경우 계산되는 가용성은 100%입니다.

일별 추세를 보려는 경우가 아니면 7일보다 더 자주 스크립트를 실행할 필요가 없습니다.

기본적으로 스크립트는 최근 7일 및 최근 30일의 데이터를 반환합니다. 데이터 간격을 더 길게 지정하면 서버의 가동 시간을 보다 정확하게 예측할 수 있습니다. 이 간격을 Operations Manager 2007 데이터베이스의 그루밍 주기보다 더 길게 설정하지 마십시오.

다음 예제에서는 오랜 기간 동안의 데이터 평균을 계산할수록 서버 가용성이 높아지는 것을 보여 줍니다.

  • 2시간 동안 컴퓨터에 대해 두 개의 이벤트가 생성된 경우 하나의 경고가 생성됩니다. 최근 7일 동안 하나의 경고가 생성된 경우 계산 방식은 다음과 같습니다.
    • 7일 동안의 총 시간 = 7 * 24 = 168
    • 총 가동 중지 시간 = 1 * 2 = 2
    • 총 가동 시간 = (168 - 2) = 166
    • 가용률 = (166 / 168) * 100 = 98.809%
  • 최근 30일 동안 하나의 경고가 생성된 경우 계산 방식은 다음과 같습니다.
    • 30일 동안의 총 시간 = 30 * 24 = 720
    • 총 가동 중지 시간 = 1 * 2 = 2
    • 총 가동 시간 = (720 - 2) = 718
    • 가용률 = (718 / 720) * 100 = 99.72%
  • 최근 84일 동안 하나의 경고가 생성된 경우 계산 방식은 다음과 같습니다.
    • 84일 동안의 총 시간 = 84 * 24 = 2016
    • 총 가동 중지 시간 = 1 * 2 = 2
    • 총 가동 시간 = (2016 - 2) = 2014
    • 가용률 = (2014 / 2016) * 100 = 99.9%

다음 예제에서는 동일한 기간 동안 추가 경고가 기록될 때마다 서버 가용성이 바뀌는 것을 보여 줍니다.

  • 최근 30일 동안 두 개의 경고가 생성된 경우 계산 방식은 다음과 같습니다.
    • 30일 동안의 총 시간 = 30 * 24 = 720
    • 총 가동 중지 시간 = 2 * 2 = 4
    • 총 가동 시간 = (720 -4) = 716
    • 가용률 = (716 / 720) * 100 = 99.44%
  • 최근 30일 동안 세 개의 경고가 생성된 경우 계산 방식은 다음과 같습니다.
    • 30일 동안의 총 시간 = 30 * 24 = 720
    • 총 가동 중지 시간 = 3 * 2 = 6
    • 총 가동 시간 = (720 -6) = 714
    • 가용률 = (714 / 720) * 100 = 99.16%

Site System Status Summarizer의 폴링 간격은 1시간으로 고정되어 있으며 SMS 관리자 콘솔을 통해 변경할 수 없습니다. 이 간격을 수정해도 이 스크립트의 정확성은 향상되지 않습니다. 이벤트 통합 간격을 변경할 수도 있지만 그래도 결과의 정확성은 향상되지 않으므로 권장되지 않습니다. 실제로 통합 간격이 2시간이면 순간적인 네트워크 정전으로 인한 잘못된 결과를 줄일 수 있으므로 통합 간격을 이보다 줄이면 결과의 신뢰도가 떨어집니다.

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


Microsoft SMS 2003의 뷰

SMS 2003 Management Pack에서는 다음과 같은 일반적인 뷰를 제공합니다.

  • 경고
  • 이벤트
  • SMS 2003 사이트 계층 구조 다이어그램
  • 상태 뷰
  • 작업 상태 뷰
  • 일반
  • 성능

SMS 2003에 맞게 사용자 지정된 다음 뷰도 제공됩니다.

SMS 2003 사이트 계층 구조 다이어그램

  • SMS 2003 계층 구조

일반

  • 최근 72시간 동안 SMS 중앙 사이트 서버에서 발생한 경고
  • 최근 72시간 동안 새로 발생한 경고

성능 뷰

특정 컴퓨터에 대한 데이터를 뷰별로 표시하도록 뷰를 구성할 수 있습니다. 이렇게 하려면 사용자 지정할 뷰를 My Workspace에 복사하고 뷰의 이름을 바꾼 다음 필요에 맞게 사용자 지정하는 것이 좋습니다. 관심 있는 컴퓨터에 대한 카운터를 개별적으로 선택하면 복잡한 그래프를 보다 단순하게 표시할 수 있습니다.

백로그\관리 지점 서버

  • 최근 48시간 동안의 DDR 백로그
  • 최근 48시간 동안의 FileCollection 백로그
  • 최근 48시간 동안의 HINV 백로그
  • 최근 48시간 동안의 릴레이 백로그
  • 최근 48시간 동안의 SINV 백로그
  • 최근 48시간 동안의 상태 백로그

백로그\사이트 서버

  • 최근 48시간 동안의 DDR 백로그
  • 최근 48시간 동안의 HINV 백로그
  • 최근 48시간 동안의 스케줄러 작업 백로그
  • 최근 48시간 동안의 스케줄러 보내기 요청 백로그
  • 최근 48시간 동안의 SINV 백로그
  • 최근 48시간 동안의 SWM 백로그

일반\관리 지점 서버

  • 최근 48시간 동안의 LogicalDisk
  • 최근 48시간 동안의 메모리
  • 최근 48시간 동안의 프로세서

일반\사이트 서버

  • 최근 48시간 동안의 LogicalDisk
  • 최근 48시간 동안의 메모리
  • 최근 48시간 동안의 프로세서
참고
최근 48시간 동안의 LogicalDisk 뷰의 성능 공급자는 Microsoft Windows Servers Base Operating System Management Pack과 함께 설치됩니다.

처리 속도

  • *최근 24시간 동안 SMS 2003 관리 지점 서버의 모든 메시지 처리 속도
  • *최근 24시간 동안 SMS 2003 관리 지점 서버의 모든 보고서 처리 속도
  • *최근 24시간 동안 SMS 2003 사이트 서버의 모든 보고서 처리 속도

처리 속도\관리 지점 서버

  • 최근 24시간 동안의 초당 DDR 수
  • 최근 24시간 동안의 초당 DM 데이터베이스 연결 시도 횟수
  • 최근 24시간 동안의 초당 DM DDR 수
  • 최근 24시간 동안의 초당 DM 검색 변환 요청 수
  • 최근 24시간 동안의 초당 DM DP 위치 수
  • 최근 24시간 동안의 초당 DM 하드웨어 인벤토리 변환 요청 수
  • 최근 24시간 동안의 초당 DM HINV 수
  • 최근 24시간 동안의 초당 DM ISAPI 요청 수
  • 최근 24시간 동안의 초당 DM 컴퓨터 설정 요청 수
  • 최근 24시간 동안의 초당 DM 패키지 버전 요청 수
  • 최근 24시간 동안의 초당 DM SINV 수
  • 최근 24시간 동안의 초당 DM 소프트웨어 정책 본문 요청 수
  • 최근 24시간 동안의 초당 DM 소프트웨어 정책 ID 요청 수
  • 최근 24시간 동안의 초당 DM 상태 수
  • 최근 24시간 동안의 초당 DM 총 설정 요청 수
  • 최근 24시간 동안의 초당 DP 위치 수
  • 최근 24시간 동안의 초당 인증 가져오기 요청 수
  • 최근 24시간 동안의 초당 정책 가져오기 요청 수
  • 최근 24시간 동안의 초당 HINV 수
  • 최근 24시간 동안의 초당 ISAPI 요청 수
  • 최근 24시간 동안의 초당 MP 위치 수
  • 최근 24시간 동안의 초당 PA 요청 수
  • 최근 24시간 동안의 초당 릴레이 보고서 수
  • 최근 24시간 동안의 초당 SINV 수
  • 최근 24시간 동안의 초당 실행된 SP 수
  • 최근 24시간 동안의 초당 상태 수
  • 최근 24시간 동안의 총 DDR 수
  • 최근 24시간 동안의 총 DM DDR 수
  • 최근 24시간 동안의 총 DM HINV 수
  • 최근 24시간 동안 디스패치된 총 DM ISAPI 요청 수
  • 최근 24시간 동안 받은 총 DM ISAPI 요청 수
  • 최근 24시간 동안의 총 DM SINV 수
  • 최근 24시간 동안의 총 DM 상태 수
  • 최근 24시간 동안의 총 HINV 수
  • 최근 24시간 동안의 총 릴레이 보고서 수
  • 최근 24시간 동안의 총 SINV 수
  • 최근 24시간 동안의 총 상태 수

처리 속도\사이트 데이터베이스 서버

  • 최근 24시간 동안의 SQL Server 사용자 연결 수

처리 속도\사이트 서버

  • 최근 24시간 동안의 분당 DDR 수
  • 최근 24시간 동안의 분당 HINV 수
  • 최근 24시간 동안의 분당 SINV 수
  • 최근 24시간 동안의 분당 상태 수
  • 최근 24시간 동안의 분당 SWM 수
  • 최근 24시간 동안의 총 DDR 수
  • 최근 24시간 동안의 총 HINV 수
  • 최근 24시간 동안의 총 SINV 수
  • 최근 24시간 동안의 총 상태 수
  • 최근 24시간 동안의 총 SWM 수

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 다이어그램

SMS 2003 Management Pack에서는 SMS 계층 구조에 대한 토폴로지 다이어그램을 제공합니다. 이 다이어그램은 사이트 서버와 사이트 시스템을 표시하고 상황에 맞는 정보로 상호 관계를 보여 줍니다. 토폴로지 다이어그램에는 계층 구조, 사이트 등의 논리적 데이터와 사이트 서버, 사이트 시스템 등의 물리적 데이터가 포함됩니다. SMS 2003 계층 구조는 매우 클 수도 있으므로 Group 필터를 사용하여 계층 구조 뷰의 범위를 SMS 2003 컴퓨터 그룹으로 지정할 수 있습니다.

Operations Manager 2007에서 SMS 2003 Management Pack에 대한 토폴로지 다이어그램을 지원하려면 다음 요구 사항을 만족해야 합니다.

  • 다이어그램을 보려는 SMS 서버에 SMS 2003 SP3이 설치되어 있어야 합니다.
  • 토폴로지 다이어그램이 사용하도록 설정되어 있어야 합니다.
  • SMS 2003 Administrator 콘솔을 사용하여 각 사이트 역할을 FQDN(정규화된 도메인 이름)으로 구성해야 합니다.

토폴로지 검색에서 SMS 2003 계층 구조의 다이어그램을 만들 수 있도록 하려면 SMS 공급자 컴퓨터가 관리되는 컴퓨터여야 하고, 이러한 컴퓨터에 에이전트가 설치되어 있어야 하며, 다른 컴퓨터에 프록시를 통해 연결하는 에이전트가 사용하도록 설정되어 있어야 합니다. 또한 사이트 서버와 사이트 시스템 간의 연결선을 표시하려면 사이트 시스템이 SMS 검색 프로세스에서 검색되고 All Systems 컬렉션의 구성원이어야 합니다.

검색은 주 사이트에서부터 사이트별로 수행되고 보조 사이트는 부모 사이트인 주 사이트가 검색될 때 함께 검색됩니다. 검색 데이터는 도구 설명 및 서버 주석을 통해 제공됩니다. 또한 다이어그램을 Microsoft Visio® 파일 형식으로 내보낼 수 있습니다.

SMS 서버 토폴로지 이미지 주석

서버 유형에 대한 아이콘

  • 데이터베이스 서버 유형: 사이트 데이터베이스
  • 사이트 시스템 유형: 관리 지점
  • 서버 유형: 중앙 사이트, 주 사이트, 보조 사이트 및 사이트 시스템

연결선

연결선 색 및 스타일은 다음과 같이 두 컴퓨터 간의 관계 유형을 나타냅니다.

  • 사이트 서버와 사이트 서버 사이의 연결선은 검은색 실선입니다.
  • 사이트 서버와 사이트 시스템 사이의 연결선은 파란색 파선입니다.

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서


SMS 2003의 보고서

이 단원에서 설명하는 보고서는 SMS 2003 Management Pack에서 사용할 수 있습니다. 보고 기능은 별도로 설치해야 하는 선택적 구성 요소입니다. 보고 서버 배포에 대한 자세한 내용은 Operations Manager 2007 제품 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

SMS 보고

Systems Management Server 2003 Management Pack에는 다음 세 가지 유형의 보고서가 포함되어 있습니다.

  • 성능
  • 구성
  • 가용성

개체 선택기를 사용하여 보고서의 대상을 그룹이나 개체로 지정합니다. 모든 보고서는 Operations Manager 2007 보고 기능을 사용하는 연결된 보고서입니다. 내보내기 가능한 7가지 보고서 형식 중에서 선택할 수 있습니다.

가용성 보고서

SMS 2003 Management Pack에는 세 가지 가용성 보고서가 있습니다. SMS 서버 그룹(Microsoft.SMS.2003.ServersGroup)을 선택하면 Microsoft.SMS.2003.ServersGroup 개체 선택기 대상에 대해 이러한 보고서를 실행할 수 있습니다.

서버 가용성 보고서

서버 가용성 보고서는 특정 서버에 있는 모든 엔터티의 집계 상태를 기반으로 합니다. 이 보고서에는 SMS 모니터 역할의 상태뿐 아니라 모니터링되는 다른 역할의 상태도 포함됩니다.

사이트 서버 가용성

사이트 서버 가용성 보고서는 사이트 서버의 상태를 기반으로 합니다. 이 보고서는 상태 모니터에서 얻은 정보를 사용합니다.

관리 지점 가용성 보고서

관리 지점 가용성 보고서는 관리 지점의 상태를 기반으로 합니다. 이 보고서는 상태 모니터에서 얻은 정보를 사용합니다.

구성 보고서

SMS 2003 Management Pack에서 사용할 수 있는 구성 보고서는 SMS 2003 서버 고객 구성 보고서 하나뿐입니다. 이 보고서는 SMS 서버나 SMS 서버 그룹에 대한 속성이 들어 있는 기본 사용자 지정 구성 보고서입니다.

이 보고서에는 다음과 같은 SMS 속성이 표시됩니다.

  • 버전(SMS 제품 버전)
  • 사이트 시스템 유형(사이트 시스템 유형, 서버 유형, 데이터베이스 서버 유형)
  • 구성 요소(사이트 서버, 서버 검색 지점, 배포 지점, 관리 지점, 보고 지점, 데이터베이스 서버, 공급자, 발신자, 클라이언트 액세스 지점)
  • 사이트 코드(SMS 사이트 코드)
  • 서버 유형(중앙, 주, 보조 사이트 서버)
  • 이름(NetBIOS 이름)
  • 데이터베이스 서버 유형(사이트 데이터베이스 서버)

이 보고서는 Microsoft.SMS.2003.ServersGroup 개체 선택기 대상 그룹에 대해 실행할 수 있습니다.

성능

성능 보고서는 먼저 모니터링할 사이트 역할을 기준으로 하여 여러 단위로 그룹화된 다음 카운터별로, 즉 속도 관련 성능 카운터(예: 초당 또는 분당)인지 아니면 원시 카운터(합계)인지에 따라 그룹화되었습니다. 이렇게 그룹화함으로써 보고서의 모든 카운터에 유사한 척도를 사용할 수 있습니다.

이 보고서는 필요한 분석 유형에 따라 개발되었습니다. 필요한 분석 유형에 따라 두 개의 보고서 집합을 사용할 수 있습니다. 한 보고서 집합에는 관리 지점이나 사이트 서버와 같은 특정 SMS 서버 역할에 대한 모든 성능 카운터가 표시됩니다. 두 번째 보고서 집합에는 모든 사이트 역할의 하드웨어 인벤토리와 같은 특정 처리 개체에 대한 카운터가 모두 표시됩니다.

SMS 2003 서버 성능 그룹 보고서

다음 보고서를 실행하려면 개체 선택기 대상 그룹에서 Microsoft.SMS.2003.ServerPerformanceGroup을 선택합니다.

SMS 2003 DDR(데이터 검색 기록) 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 DDR(데이터 검색 기록) 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 DDR 백로그 | 대기열에 들어간 총 DDR 수
SMS 2003 성능 측정: 사이트 서버의 처리된 총 DDR 수 | 처리된 총 DDR 수
SMS 2003 성능 측정: MP DDR 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP DDR Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 DDR 수 | 생성된 총 검색 보고서 수

SMS 2003 DDR(데이터 검색 기록) 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 DDR(데이터 검색 기록) 처리 속도가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 DDR 처리 속도 | 처리된 DDR 수/분
SMS 2003 성능 측정: MP DDR Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: DMP DDR 처리 속도 | 생성된 검색 보고서 수/초

SMS 2003 HINV(하드웨어 인벤토리) 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 HINV(하드웨어 인벤토리) 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 HINV 백로그 | 대기열에 들어간 총 MIF 수
SMS 2003 성능 측정: 사이트 서버의 처리된 총 HINV 수 | 처리된 총 MIF 수
SMS 2003 성능 측정: MP HINV 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP HINV Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 HINV 수 | 생성된 총 하드웨어 인벤토리 보고서 수

SMS 2003 HINV(하드웨어 인벤토리) 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 HINV(하드웨어 인벤토리) 처리 속도가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 HINV 처리 속도 | 처리된 MIF 수/분
SMS 2003 성능 측정: MP HINV Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP HINV Retry Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: DMP HINV 처리 속도 | 생성된 하드웨어 인벤토리 보고서 수/초

SMS 2003 SINV(소프트웨어 인벤토리) 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 SINV(소프트웨어 인벤토리) 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 SINV 백로그 | 대기열에 들어간 총 SINV 수
SMS 2003 성능 측정: 사이트 서버의 처리된 총 SINV 수 | 처리된 총 SINV 수
SMS 2003 성능 측정: MP FileCollection 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP SINV 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP SINV Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 SINV 수 | 생성된 총 소프트웨어 인벤토리 보고서 수

SMS 2003 SINV(소프트웨어 인벤토리) 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 SINV(소프트웨어 인벤토리) 처리 속도가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 SINV 처리 속도 | 처리된 SINV 수/분
SMS 2003 성능 측정: MP SINV Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP SINV ColFile Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: DMP SINV 처리 속도 | 생성된 소프트웨어 인벤토리 보고서 수/초

SMS 2003 서버 시스템 리소스 성능

이 보고서에는 SMS 서버 역할별 시스템 리소스 사용량이 표시됩니다.

SMS 2003 성능 측정: 메모리 - %사용 중인 커밋된 바이트 | 사용 중인 커밋된 바이트
SMS 2003 성능 측정: 페이징 파일 - %사용 | % 사용
SMS 2003 성능 측정: 프로세서 - % 프로세서 시간(_Total) | % 프로세서 시간
SMS 2003 성능 측정: 프로세스 - % 프로세서 시간(smsexec) | % 프로세서 시간
SMS 2003 성능 측정: 프로세스 - % 프로세서 시간(ccmexec) | % 프로세서 시간
SMS 2003 성능 측정: 시스템 - 시스템 가동 시간 | 시스템 가동 시간

SMS 2003 SWM(소프트웨어 미터링) 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 SWM(소프트웨어 미터링) 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 SWM 백로그 | 대기열에 들어간 총 SWM 사용 파일 수
SMS 2003 성능 측정: 사이트 서버의 처리된 총 SWM 수 | 처리된 총 SWM 사용 레코드 수
SMS 2003 성능 측정: MP Relay Mgr 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP Relay Mgr(총 보고서 수) | 총 보고서 수

SMS 2003 SWM(소프트웨어 미터링) 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 SWM(소프트웨어 미터링) 처리 속도가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 SWM 처리 속도 | 처리된 SWM 사용 레코드 수/분
SMS 2003 성능 측정: MP Relay Mgr(총 보고서 수/초) | 총 보고서 수/초

SMS 2003 상태 메시지 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 SMS 상태 메시지 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버의 처리된 총 상태 메시지 수 | 받은 상태 메시지 수
SMS 2003 성능 측정: MP 상태 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP Status Mgr(총 이벤트 수) | 총 이벤트 수
SMS 2003 성능 측정: DMP의 처리된 총 상태 메시지 수 | 발생한 총 상태 메시지 수

SMS 2003 상태 메시지 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 SMS 상태 메시지 처리 속도가 표시됩니다.

SMS 2003 성능 측정: 사이트 서버 상태 처리 속도 | 처리된 상태 메시지 수/초
SMS 2003 성능 측정: MP Status Mgr(총 이벤트 수/초) | 총 이벤트 수/초
SMS 2003 성능 측정: DMP 상태 처리 속도 | 발생한 상태 메시지 수/초

SMS 2003 서버 역할 지원 성능

이 보고서에는 SMS 서버 역할을 지원하는 서비스의 성능이 표시됩니다.

SMS 2003 성능 측정: 웹 서비스(ISAPI 확장 요청 수/초) | ISAPI 확장 요청 수/초
SMS 2003 성능 측정: SMS SQL 연결 수 | 사용자 연결 수

SMS 2003 관리 지점 서버 보고서

다음 보고서를 실행하려면 개체 선택기 대상 그룹에서 Microsoft Management Point Servers를 선택합니다.

SMS 2003 장치 관리 지점 원시 성능

이 보고서에는 SMS 장치 관리 지점 서버 역할에 대해 처리된 합계가 표시됩니다.

SMS 2003 성능 측정: DMP의 처리된 총 DDR 수 | 생성된 총 검색 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 HINV 수 | 생성된 총 하드웨어 인벤토리 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 SINV 수 | 생성된 총 소프트웨어 인벤토리 보고서 수
SMS 2003 성능 측정: DMP의 처리된 총 상태 메시지 수 | 발생한 총 상태 메시지 수
SMS 2003 성능 측정: DMP의 디스패치된 총 ISAPI 요청 수 | 디스패치된 총 메시지 수
SMS 2003 성능 측정: DMP의 받은 총 ISAPI 요청 수 | 받은 총 메시지 수

SMS 2003 장치 관리 지점 속도 성능

이 보고서에는 SMS 장치 관리 지점 서버 역할의 처리 속도가 표시됩니다.

SMS 2003 성능 측정: DMP 설정 요청 속도 | DMP 설정 요청 수/초
SMS 2003 성능 측정: DMP 컴퓨터 설정 요청 속도 | 컴퓨터 설정 요청 수/초
SMS 2003 성능 측정: DMP 소프트웨어 정책 ID 요청 속도 | 소프트웨어 정책 ID 요청 수/초
SMS 2003 성능 측정: DMP 소프트웨어 정책 본문 요청 속도 | 소프트웨어 정책 본문 요청 수/초
SMS 2003 성능 측정: DMP 패키지 버전 요청 속도 | 패키지 버전 요청 수/초
SMS 2003 성능 측정: DMP 검색 변환 요청 속도 | 검색 변환 요청 수/초
SMS 2003 성능 측정: DMP 하드웨어 인벤토리 변환 요청 속도 | 하드웨어 인벤토리 변환 요청 수/초
SMS 2003 성능 측정: DMP 데이터베이스 연결 시도 속도 | 데이터베이스 연결 시도 횟수/초
SMS 2003 성능 측정: DMP DDR 처리 속도 | 생성된 검색 보고서 수/초
SMS 2003 성능 측정: DMP HINV 처리 속도 | 생성된 하드웨어 인벤토리 보고서 수/초
SMS 2003 성능 측정: DMP DP 위치 요청 처리 속도 | 생성된 위치 요청 수/초
SMS 2003 성능 측정: DMP ISAPI 메시지 처리 속도 | 디스패치된 메시지 수/초
SMS 2003 성능 측정: DMP SINV 처리 속도 | 생성된 소프트웨어 인벤토리 보고서 수/초
SMS 2003 성능 측정: DMP 상태 처리 속도 | 발생한 상태 메시지 수/초

SMS 2003 관리 지점 원시 성능

이 보고서에는 SMS 관리 지점 서버 역할에 대해 처리된 백로그 및 합계가 표시됩니다.

SMS 2003 성능 측정: MP DDR 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP DDR Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: MP HINV 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP HINV Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: MP FileCollection 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP SINV 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP SINV Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: MP Relay Mgr 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP Relay Mgr(총 보고서 수) | 총 보고서 수
SMS 2003 성능 측정: MP 상태 백로그 | 대기 중인 메시지 수
SMS 2003 성능 측정: MP Status Mgr(총 이벤트 수) | 총 이벤트 수

SMS 2003 관리 지점 속도 성능

이 보고서에는 SMS 관리 지점 서버 역할의 처리 속도가 표시됩니다.

SMS 2003 성능 측정: MP Location Mgr(MP 요청 수/초) | MP 요청 수/초
SMS 2003 성능 측정: MP Location Mgr(DP 요청 수/초) | DP 요청 수/초
SMS 2003 성능 측정: MP 정책 가져오기(요청 수/초) | 요청 수/초
SMS 2003 성능 측정: MP 인증 가져오기(요청 수/초) | 요청 수/초
SMS 2003 성능 측정: MP Policy Mgr(PA 요청 수/초) | PA 요청 수/초
SMS 2003 성능 측정: MP DAL(실행된 SP 수/초) | 실행된 SP 수/초
SMS 2003 성능 측정: MP HINV Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP HINV Retry Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP SINV Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP SINV ColFile Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP Relay Mgr(총 보고서 수/초) | 총 보고서 수/초
SMS 2003 성능 측정: MP Status Mgr(총 이벤트 수/초) | 총 이벤트 수/초

참고 항목

개념

Microsoft System Management Server 2003 Management Pack용 추가 리소스
SMS 2003 Management Pack의 사이트 및 구성 요소
SMS 2003의 컴퓨터 그룹
SMS 2003의 규칙 그룹
SMS 2003의 공급자
SMS 2003의 스크립트
Microsoft SMS 2003의 뷰
SMS 2003의 다이어그램
SMS 2003의 보고서